Go Back   Cockos Incorporated Forums > REAPER Forums > Dstruct's Casa De Nitpicks

Reply
 
Thread Tools Display Modes
Old 09-14-2022, 07:28 AM   #1
juan_r
Human being with feelings
 
juan_r's Avatar
 
Join Date: Oct 2019
Posts: 685
Default Reaper always on top until minimized despite click on other windows (SOLVED)

This behavior is new, I think. It started with 6.66 or 6.67, if I'm not mistaken. Not a bug, but unexpected - so it belongs with the nitpicks.

OS: Windows 10, kept updated.

Issue: When I first launch Reaper, it stays in front of all other application windows, even if I click on one of the other windows to bring it to the foreground. Windows Explorer, Notepad, other editors - whatever. The only way to make Reaper like the other windows, which move between background and foreground depending on their focus, is to minimize Reaper first, and then bring it back up to non-minimized state. Only now can other windows go in front of Reaper.

It sounds almost like a Windows - not Reaper - issue, but it happens only with Reaper and, as I said, is a behavior not observed previously.
__________________
My ReaPack repository: https://github.com/juanriccio/Reaper...ster/index.xml

Last edited by juan_r; 09-28-2022 at 03:23 AM. Reason: Change title to add useful keywords including SOLVED
juan_r is offline   Reply With Quote
Old 09-14-2022, 09:46 AM   #2
Edgemeal
Human being with feelings
 
Edgemeal's Avatar
 
Join Date: Apr 2016
Location: ASU`ogacihC
Posts: 3,084
Default

Weird, not seeing that here (Win10_x64).

Maybe an extension or script doing something on launch?
Try a clean portable install?
Edgemeal is offline   Reply With Quote
Old 09-14-2022, 10:57 AM   #3
juan_r
Human being with feelings
 
juan_r's Avatar
 
Join Date: Oct 2019
Posts: 685
Default

Right @Edgemeal, a fresh portable install doesn't do that. I wonder which setting I've touched... not that it's too important, but it's a slight itch in the back of my mind
__________________
My ReaPack repository: https://github.com/juanriccio/Reaper...ster/index.xml
juan_r is offline   Reply With Quote
Old 09-21-2022, 08:54 AM   #4
juan_r
Human being with feelings
 
juan_r's Avatar
 
Join Date: Oct 2019
Posts: 685
Default

I've found a Reaper backup with a reaper.ini pre-dating the onset of this problem. If I switch INIs, the glitch disappears. I have changed quite a few settings from then, though, and I don't remember all of them. For this reason, I'd like to keep my present INI file and only change the specific setting that triggered the always-on-top problem.

Here's the output of
Code:
diff old-reaper-no-bug.ini todays-reaper-bug.ini
edited to remove all the "recent=..." lines, which are likely not relevant. What could the culprit be?

Code:
8c8
< prefspage=154
---
> prefspage=478
17,18c17,18
< fxadd_x=60
< fxadd_y=291
---
> fxadd_x=511
> fxadd_y=172
22,23c22,23
< wnd_x=170
< wnd_y=62
---
> wnd_x=279
> wnd_y=73
142c142
< viewadvance=18
---
> viewadvance=19
218c218
< env_reduce=3
---
> env_reduce=1027
225c225
< pooledenvs=32
---
> pooledenvs=288
271c271
< dockersel0=mixer
---
> dockersel0=Default_6.0_theme_adjuster.lua
284c284
< leftpanewid=406
---
> leftpanewid=379
313,314c313,314
< mixrowflags=48
< envattach=1
---
> mixrowflags=49
> envattach=4
490c490
< aot=0
---
> aot=1
500,501c500,501
< routingwnd_w=554
< routingwnd_h=516
---
> routingwnd_w=1514
> routingwnd_h=808
712c712
< custommenu=4
---
> custommenu=260
801d800
< lastactionfilt="envelope "
802a802
> hwoutfx_bypass=1
815c815
< lastt=1660761098
---
> lastt=1663080607
912c912
< curtab_0=0
---
> curtab_0=2
915c915
< curtab_1=0
---
> curtab_1=2
940c940
< tabsort_2=0
---
> tabsort_2=9
944a945
> colwid_57=94
961c962
< lastspac=0.25000000
---
> lastspac=0.50000000
965c966
< quantmode=273
---
> quantmode=4353
971c972
< quantswingstrength=0.000000
---
> quantswingstrength=0.200000
985c986
< colorwhat=0
---
> colorwhat=2
1109,1110c1110,1111
< wnd_left=98
< wnd_top=617
---
> wnd_left=123
> wnd_top=516
1193c1194
< BR - StartupVersionCheck=1 1 1660836150
---
> BR - StartupVersionCheck=1 1 1663724406
1258c1259
< lastdir=pre
---
> lastdir=D:\Sample-Libs\Misc.Samples
1262c1263
< NbShortcuts=8
---
> NbShortcuts=7
1624c1624
< watch_lx=59
---
> watch_lx=62
1626c1626
< watch_lw=1296
---
> watch_lw=1293
__________________
My ReaPack repository: https://github.com/juanriccio/Reaper...ster/index.xml
juan_r is offline   Reply With Quote
Old 09-27-2022, 12:57 PM   #5
jayse
Human being with feelings
 
Join Date: Oct 2016
Posts: 9
Default

It's happening on my system as well. I'm currently running v6.68 on Windows 10.
jayse is offline   Reply With Quote
Old 09-27-2022, 05:52 PM   #6
juan_r
Human being with feelings
 
juan_r's Avatar
 
Join Date: Oct 2019
Posts: 685
Default

Still there in v6.68, yes. Do you have an old reaper.ini file that makes the problem go away? Someone may be able to spot a pattern.
__________________
My ReaPack repository: https://github.com/juanriccio/Reaper...ster/index.xml
juan_r is offline   Reply With Quote
Old 09-27-2022, 06:18 PM   #7
Edgemeal
Human being with feelings
 
Edgemeal's Avatar
 
Join Date: Apr 2016
Location: ASU`ogacihC
Posts: 3,084
Default

I don't have aot=1, so I added that to my reaper.ini and it acts like you describe! So try changing that to =0 or just remove that line.

Hmmm, AOT is usually short for Always On Top, but I don't see an option in REAPER for that.

EDIT: Main Menu > View > Always On Top
I didn't see that option because its hidden in my custom menu, but enabling that adds aot=1 to the ini file.

Last edited by Edgemeal; 09-27-2022 at 06:31 PM.
Edgemeal is offline   Reply With Quote
Old 09-28-2022, 03:20 AM   #8
juan_r
Human being with feelings
 
juan_r's Avatar
 
Join Date: Oct 2019
Posts: 685
Default

Aha @Edgemeal you nailed it!

In hindsight, I've been kind of dumb not to notice the explicit option. I have been looking in all the wrong places (Preferences, reaper.ini).

These forums are a real asset. Thank you!
__________________
My ReaPack repository: https://github.com/juanriccio/Reaper...ster/index.xml
juan_r is offline   Reply With Quote
Old 09-28-2022, 08:32 AM   #9
Edgemeal
Human being with feelings
 
Edgemeal's Avatar
 
Join Date: Apr 2016
Location: ASU`ogacihC
Posts: 3,084
Default

OK Great!
So the Always On Top feature is actually buggy, it shouldn't stop working when you minimize/restore REAPER. Pinned floating windows had that same bug and was fixed awhile back.
Edgemeal is offline   Reply With Quote
Old 09-28-2022, 11:35 AM   #10
jayse
Human being with feelings
 
Join Date: Oct 2016
Posts: 9
Default

Changing the value of aot from 1 to 0 in REAPER.ini worked for me as well. Thanks very much for the tip.
jayse is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 12:33 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.