Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER OS X Forum

Reply
 
Thread Tools Display Modes
Old 09-19-2014, 01:33 AM   #1
stilgherrian
Human being with feelings
 
Join Date: Jan 2010
Location: Sydney, Australia
Posts: 2
Default Reaper 4.73 for OS X 64-bit not correctly signed?

I just did an upgrade of REAPER64.app for OS X to version 4.73, from the disc image reaper473_x86_64.dmg downloaded just now.

When I tried launching it, I got the error "“REAPER64.app” can’t be opened because the identity of the developer cannot be confirmed." I have my system's security settings set to allow apps downloaded from "Apple Mac Store and identified developers", which is how it's usually been when upgrading Reaper, and this error has not been triggered.

Is there a problem with Reaper's Apple developer certificate?

If so, is the MD5 or SHA1 or some other hash of the .dmg file available somewhere?
stilgherrian is offline   Reply With Quote
Old 09-19-2014, 06:05 AM   #2
hotsaucejalapeno
Human being with feelings
 
hotsaucejalapeno's Avatar
 
Join Date: Jan 2013
Location: Florida
Posts: 251
Default

I had the same problem. I got it to run by going into "Security & Privacy" after trying to run REAPER and at the bottom of the window you should see something that lets you run REAPER anyways without changing your settings.

Otherwise, you can just change your "Allow apps downloaded from:" settings to "Anywhere".
hotsaucejalapeno is offline   Reply With Quote
Old 09-20-2014, 07:16 AM   #3
vdubreeze
Human being with feelings
 
vdubreeze's Avatar
 
Join Date: Jul 2011
Location: Brooklyn
Posts: 764
Default

Also, whenever this happens with an OS X app you've downloaded and trust but that doesn't automatically get Apple's approval you can, instead of clicking on the icon (which denies and requires a trip to system prefs to let it open) hold down on the icon while holding the control key. It gives a list of actions including simply open and when you do it from here it just asks to verify that you want to and then it will open.
vdubreeze is offline   Reply With Quote
Old 09-20-2014, 11:59 PM   #4
stilgherrian
Human being with feelings
 
Join Date: Jan 2010
Location: Sydney, Australia
Posts: 2
Default

Thanks to both of you, and it's good to know that others encountered the same problem.

But my question wasn't really about how to lower the security settings to run a program that hadn't been properly signed. It was more about confirming that it actually IS the valid program, rather than a potentially-malicious substitute — because previous versions had been correctly signed.

I guess I should probably check directly with Cockos.
stilgherrian is offline   Reply With Quote
Old 09-25-2014, 02:23 AM   #5
Tibor
Human being with feelings
 
Join Date: Sep 2014
Posts: 4
Default

Hi a greetings,

new here (using Reaper64 - still evaluating - on 10.9.5.).

I also got the "can’t be opened because the identity of the developer cannot be confirmed" message. Then I did the control-click thing. Than Reaper opened.

However, now every time I start Reaper I get the warning message that Reaper was downloaded from the internet and whether I am sure that I want to open it!

How can I tell the system that this is a safe app , so that the system won't give me the warning every time I want to start Reaper (other than allowing apps downloaded from anywhere). Does Cockos need to register with Apple as "identified developer"?

Tibor
Tibor is offline   Reply With Quote
Old 09-25-2014, 05:46 AM   #6
Ollie
Super Moderator (no feelings)
 
Ollie's Avatar
 
Join Date: Dec 2007
Location: On or near a dike
Posts: 9,632
Default

Are you guys all running 10.9.5.?
Ollie is offline   Reply With Quote
Old 09-25-2014, 08:45 AM   #7
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 10,320
Default

Ah, Apple broke everything in 10.9.5 on purpose. New REAPER 4.73 images (same builds with the new signing) are available here:

http://landoleet.org/reaper473_i386s.dmg (32 bit)
http://landoleet.org/reaper473_x86_64s.dmg (64 bit)

Please test and post here with any results, we will move them to the main web site once we have some feedback.

Reference for the signing changes (makes our building process more difficult, thanks Apple):

https://developer.apple.com/library/...9-CH1-TNTAG205

Quote:
Important: For your apps to run on updated versions of OS X they must be signed on OS X version 10.9 or later and thus have a version 2 signature.
and
Quote:
Note: It is necessary to sign code while running OS X Mavericks to get a version 2 signature. The actual code signing machinery is part of the operating system, not the codesign tool. It will not work to copy the codesign tool from Mavericks to an older OS X version.
Seriously? Ugh.
Justin is online now   Reply With Quote
Old 09-25-2014, 03:36 PM   #8
Tale
Human being with feelings
 
Tale's Avatar
 
Join Date: Jul 2008
Location: Holland
Posts: 2,808
Default

Yikes!
Tale is offline   Reply With Quote
Old 09-25-2014, 08:15 PM   #9
Jacos
Human being with feelings
 
Join Date: Jun 2014
Location: New Zealand
Posts: 227
Default

Is it not ok, to override the Gatekeeper function of Mavericks, by right-clicking on icons of downloads, then choosing Open? I am running OS 10.9.5 and the recent Reaper downloads, no problems opening them and no extra steps required. This is how I have to open most software I buy now. I think I learnt this tip from a major DAW's Tech Support site.
Jacos is offline   Reply With Quote
Old 09-25-2014, 10:39 PM   #10
triton60
Human being with feelings
 
Join Date: Aug 2012
Posts: 43
Default

Quote:
Originally Posted by Justin View Post
Ah, Apple broke everything in 10.9.5 on purpose. New REAPER 4.73 images (same builds with the new signing) are available here:

http://landoleet.org/reaper473_i386s.dmg (32 bit)
http://landoleet.org/reaper473_x86_64s.dmg (64 bit)

Please test and post here with any results, we will move them to the main web site once we have some feedback.

Reference for the signing changes (makes our building process more difficult, thanks Apple):

https://developer.apple.com/library/...9-CH1-TNTAG205


and

Seriously? Ugh.
This is the utter rubbish you have to put up with developing on any Apple platform, it is their way to keep getting their customers to update a perfectly fine functioning computer.
triton60 is offline   Reply With Quote
Old 09-26-2014, 12:03 AM   #11
Tibor
Human being with feelings
 
Join Date: Sep 2014
Posts: 4
Default

Thanks! I installed it, and will try it later today.

Quote:
Originally Posted by Justin View Post
Ah, Apple broke everything in 10.9.5 on purpose. New REAPER 4.73 images (same builds with the new signing) are available here:

http://landoleet.org/reaper473_i386s.dmg (32 bit)
http://landoleet.org/reaper473_x86_64s.dmg (64 bit)
....
Tibor is offline   Reply With Quote
Old 09-26-2014, 02:10 AM   #12
Tibor
Human being with feelings
 
Join Date: Sep 2014
Posts: 4
Default

So I installed http://landoleet.org/reaper473_x86_64s.dmg (is the app dated 17 Sep 2014 17:00 ??) but I still get the warning that Reaper64 is an application downloaded from the internet and whether I am sure I want to open it, or something.
Tibor is offline   Reply With Quote
Old 09-26-2014, 02:14 AM   #13
Tale
Human being with feelings
 
Tale's Avatar
 
Join Date: Jul 2008
Location: Holland
Posts: 2,808
Default

Quote:
Originally Posted by Tibor View Post
So I installed [...] (is the app dated 17 Sep 2014 17:00 ??) but I still get the warning that Reaper64 is an application downloaded from the internet and whether I am sure I want to open it, or something.
I always get that warning, even on OSX 10.6.8 (which AFAIK doesn't support code signing at all), so I assume that is just how it works on OSX.
Tale is offline   Reply With Quote
Old 09-26-2014, 02:19 AM   #14
Tibor
Human being with feelings
 
Join Date: Sep 2014
Posts: 4
Default

Quote:
Originally Posted by Tale View Post
I always get that warning, even on OSX 10.6.8 (which AFAIK doesn't support code signing at all), so I assume that is just how it works on OSX.
But it never happened to me before 10.9.5 . So, really the only way to get rid of that message that I allow running anything in the system preferences?
Tibor is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:24 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.