Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER OS X Forum

Reply
 
Thread Tools Display Modes
Old 03-13-2016, 08:32 AM   #1
mitohund
Human being with feelings
 
Join Date: Mar 2016
Posts: 4
Default Only 8kHz playback over Bluetooth (Bose Soundlink Mini II)

Hi

I'm new to this forum and also Reaper itself, but our recording engineer swears by Reaper, so I'm trying to use it as well, to simplify the process. And I have an issue that I can't find a solution for, not here and not on Google. But I do apologise in advance if I am double posting after all.

Here's the issue: I only need to listen through various takes that my recording engineer sends me. So studio sound quality is not at all required here. I'm on a MacBook Pro 11,1 and need to regularly watch video and audio edits of other team members, keeping a "consumer perspective" (i.e. not studio environment, but typical consumer devices and environments). To boost the volume of my MacBook, a Bose Soundlink Mini II is connected via Bluetooth. In no software (Premiere Pro, After Effects, Audition, VLC, etc.) has this ever been an issue (which actually even surprised me a bit). Except for Reaper, where the audio quality is reduced from 48kHz to 8kHz the moment the Soundlink is chosen as the active audio device.

I have tried various settings in general preferences as well as project settings, but nothing seems to work. Can anybody suggest something I could try? That would be amazing.
mitohund is offline   Reply With Quote
Old 03-18-2016, 01:36 AM   #2
mitohund
Human being with feelings
 
Join Date: Mar 2016
Posts: 4
Default

Anyone? Would be grateful for any hints.
mitohund is offline   Reply With Quote
Old 03-18-2016, 10:25 AM   #3
serr
Human being with feelings
 
Join Date: Sep 2010
Posts: 6,438
Default

Obviously we aren't going to be expecting anything beyond the lowest fidelity "portable" standards from Bose (Better Off with Something Else, etc, etc), and further a bluetooth device. You made the same observation.

But... the thing only runs at 8k sample rate ?!?!

I suppose I might think "Bose... bluetooth... Max high frequency response of 4khz eh? Alright then..." But I'd be just as surprised.

What happens when you try to set it to 44.1k or 48k? (I assume we're not even considering HD sample rates.) What happens when you hit the 'apply' button in the Preferences/Audio/Device page? Does it just stubbornly stay at 8k?

Have you also tried to control it with Audio MIDI Setup? What happens there? (My understanding is that the lowest sample rate allowed should be 44.1k with the built-in audio interface. You shouldn't see any other options in the menu.)
__________________
Mac Pro 8x3.33GHz i7, 16GB, 256GB SSD(OS, apps), 3x2TB 7200 HD(data); MacBook Pro 2.8GHz, 6GB, 128GB SSD HD(OS, apps), 750GB 7200 HD(data); 2xTrue Precision 8; Apogee AD-16; 2xMOTU 828mk3, Evolution UC-33e; Faderport; WiRanger, iPad & the analog mixer has retired
serr is online now   Reply With Quote
Old 03-18-2016, 11:02 AM   #4
xaverle
Human being with feelings
 
Join Date: Sep 2014
Posts: 32
Default

Hi,
I`m on WIN 8.1 and also own a soundlink2.
I was curios if it works with Reaper and without cable.
In the ASIO4all wrapper the SL appeared 2 Times, one of this items was the "Bose Handsfree" this seems to be used for incoming phonecalls an has 8kHz, try searching for the other unit..its 44,1.
After fiddling around with it Reaper and Windows crashed completely and it took half an hour to get things back to prober work...:-(
USE CABLES....
xaverle is offline   Reply With Quote
Old 03-18-2016, 11:10 AM   #5
karbomusic
Human being with feelings
 
karbomusic's Avatar
 
Join Date: May 2009
Posts: 19,681
Default

Just as an FYI, I have several BT devices capable of 44k. I have one that I use to listen to mono mixes in different rooms like below. Keep in mind, on mine I had to select it specifically, it didn't magically default to 44k because there were settings for phone type use and audio use and it defaulted to phone.

__________________
Choosing to play the simpler part instead of the fancier one, takes a lot of courage
karbomusic is online now   Reply With Quote
Old 03-19-2016, 02:37 AM   #6
cyrano
Human being with feelings
 
cyrano's Avatar
 
Join Date: Jun 2011
Location: Belgium
Posts: 2,550
Default

I've never invested any time in BT, but the latest version is capable of 48 kHz. Maybe that Bose thing is the previous generation?

And as far as I have looked at Bose's way of doing things, I remember they don't follow standards. They USE standards and then rape them just enough to make sure their own gear works a little better.
__________________
Next thing on the todo list: introduce your paranoia to your imagination.
cyrano is offline   Reply With Quote
Old 02-21-2017, 10:47 PM   #7
yonkiman
Human being with feelings
 
Join Date: Jan 2016
Posts: 3
Default

I just downloaded Reaper and am having the same problem - my normally pretty good-sounding bluetooth stereo earbuds drop to 8kHz 24bit (!!!) mono when I select them as Reaper's audio device. I've requested 48kHz, 44.1kHz, and 32kHz in Reaper's Audio Device Settings, but all I can get is 8kHz.

All other software on my Mac plays music in glorious 48kHz...

Did anyone get anywhere with this issue?
yonkiman is offline   Reply With Quote
Old 02-22-2017, 07:56 AM   #8
serr
Human being with feelings
 
Join Date: Sep 2010
Posts: 6,438
Default

Pick your battles.
Some of the portable device thingies available these days ARE convenient. But some of them...

Are you also eating that watermelon with a straw while you listen to those bluetooth headphones?

This is one of those cases where a simple wire is better and actually easier to use. Any cheapo headphones will sound magnitudes better. Treat yourself to a pair of Sennheiser HD280 if you want to spend $90. (You could easily spend more than that in time/hassle trying to pass audio through a wireless system so very much not ever intended to handle anywhere close to that bandwidth.)

Bluetooth is good for keyboard/mouse and grabbing pictures from your phone (unless you bought a cheap Android phone where the bluetooth radio fails after 3 weeks - then it's back to the little USB cable).
__________________
Mac Pro 8x3.33GHz i7, 16GB, 256GB SSD(OS, apps), 3x2TB 7200 HD(data); MacBook Pro 2.8GHz, 6GB, 128GB SSD HD(OS, apps), 750GB 7200 HD(data); 2xTrue Precision 8; Apogee AD-16; 2xMOTU 828mk3, Evolution UC-33e; Faderport; WiRanger, iPad & the analog mixer has retired
serr is online now   Reply With Quote
Old 02-22-2017, 09:18 AM   #9
yonkiman
Human being with feelings
 
Join Date: Jan 2016
Posts: 3
Default

Ah...I see what's going on here. A few things:

1) I'm using Bluetooth earbuds because I'm next to my wife who's asleep in bed. I just downloaded Reaper and wanted to learn the Reaper features and workflow by experimenting and watching some of the many awesome Reaper tutorials. I don't need the highest in hi-if for that.

2) While I don't believe you had anything but the best intentions with your response, you changed my question (and the OP's) about what appears to be an actual bug (Reaper is not configuring some BT audio devices correctly on OS X) to an opinion piece about my audio quality decisions. Again though, I know you were just trying to help. However now that we're on the subject...

3) I don't know if you've actually *tried* the latest Bluetooth 4.0 earbuds, but they sound *really* good. Surprisingly good. I bought these https://www.amazon.com/Anker-SoundBu.../dp/B016Y8XJCW for $30 and I've heard a lot of wired headphones and speakers that sound worse. I certainly don't mind listening to music on them at night. (If anyone wants to try them I recommend you also get these $10 replacement ear tips https://www.amazon.com/gp/product/B00G1WA4RA - the Anker tips don't fit as comfortably or seal as well.)

4) There's also a tradition through the decades of mixing music so it sounds good on the popular platforms of the day. (In the 60s you'd better make sure your single sounded good on an AM radio with a 2" speaker.) So even if BT headphone quality is as bad as you think it is, there's still a case for using them since that's the delivery system a lot of today's music market is using.

Again, I do appreciate the well-intentioned response. I just wish someone had an answer to my technical question.
yonkiman is offline   Reply With Quote
Old 02-22-2017, 09:37 AM   #10
serr
Human being with feelings
 
Join Date: Sep 2010
Posts: 6,438
Default

Quote:
Originally Posted by yonkiman View Post
While I don't believe you had anything but the best intentions with your response, you changed my question (and the OP's) about what appears to be an actual bug (Reaper is not configuring some BT audio devices correctly on OS X) to an opinion piece about my audio quality decisions.
What I meant was more like:
Are you sure they aren't working as intended? (ie @8kHz)
And it thus becomes a case of the workaround being more work than the work.

I do lo-fi things too. Listening to a mix in progress on various lo-fi thingies is mandatory IMHO. No argument there! (I also watch movies on my 15" laptop with the built-in speakers because I truly don't care about quality for movies like I do for music.)

So, I was genuinely asking if this wasn't a case of expecting too much from a portable device. Also based on all these type of devices I see in Worst Purchase type stores that are often less convenient than simpler solutions.

But if it is a bug, it should absolutely be fixed!
__________________
Mac Pro 8x3.33GHz i7, 16GB, 256GB SSD(OS, apps), 3x2TB 7200 HD(data); MacBook Pro 2.8GHz, 6GB, 128GB SSD HD(OS, apps), 750GB 7200 HD(data); 2xTrue Precision 8; Apogee AD-16; 2xMOTU 828mk3, Evolution UC-33e; Faderport; WiRanger, iPad & the analog mixer has retired
serr is online now   Reply With Quote
Old 02-22-2017, 09:47 AM   #11
karbomusic
Human being with feelings
 
karbomusic's Avatar
 
Join Date: May 2009
Posts: 19,681
Default

In my case (windows) there was a separate device/driver for each sample rate, thusly I had to make sure I chose the right one in reaper order to get 48K IIRC, YMMV. Reaper shouldn't really care, it should use the driver and sample rate you point it to, in windows anyway.
__________________
Choosing to play the simpler part instead of the fancier one, takes a lot of courage
karbomusic is online now   Reply With Quote
Old 02-23-2017, 12:43 PM   #12
mitohund
Human being with feelings
 
Join Date: Mar 2016
Posts: 4
Default

Sorry I'm responding so late, but I solved my original issue. I meant to post the solution here, but since I had only sorted it out months later I forgot.

Anyway, the solution is actually quite simple:
In you macOS system settings choose your Bluetooth device as the output device, but the internal microphone as the input device. Then set Reaper to use the "default system devices" (NOT your Bluetooth device). Done (hopefully).

Turns out the Bose Soundlink Mini II has 44.1K output quality, but only 8K input quality – and I'm guessing Reaper can only have one sample rate in the project, so it chooses the lower one.

If the above doesn't work for you, verify the following:
- check "Request sample rate: 44100"
- under "Audio MIDI Setup..." set your Bluetooth OUTPUT device to "44100,0 Hz"
mitohund is offline   Reply With Quote
Old 02-23-2017, 02:08 PM   #13
yonkiman
Human being with feelings
 
Join Date: Jan 2016
Posts: 3
Default

That did the trick (after exiting and restarting Reaper, anyway). Thanks!
yonkiman is offline   Reply With Quote
Old 02-23-2017, 02:44 PM   #14
mitohund
Human being with feelings
 
Join Date: Mar 2016
Posts: 4
Default

Good to hear. Have fun with it!
mitohund is offline   Reply With Quote
Old 02-23-2017, 03:36 PM   #15
serr
Human being with feelings
 
Join Date: Sep 2010
Posts: 6,438
Default

Interesting.

So when you select the device itself (which has both input and output ports), it must be run at the lowest common denominator setting for it's input. But letting core audio run it instead, because core audio treats inputs and outputs as separate devices gives you a workaround.

Well... Go OSX!
And go Reaper for having the comprehensive audio interface feature set!!
__________________
Mac Pro 8x3.33GHz i7, 16GB, 256GB SSD(OS, apps), 3x2TB 7200 HD(data); MacBook Pro 2.8GHz, 6GB, 128GB SSD HD(OS, apps), 750GB 7200 HD(data); 2xTrue Precision 8; Apogee AD-16; 2xMOTU 828mk3, Evolution UC-33e; Faderport; WiRanger, iPad & the analog mixer has retired
serr is online now   Reply With Quote
Old 09-24-2017, 10:56 AM   #16
Travesty
Human being with feelings
 
Join Date: Nov 2014
Posts: 201
Default

I've encountered the same issue on windows 10. windows is defaulting to the hands free driver which is 8k. not a reaper or osx issue.

not sure how to fix it though ...
Travesty is offline   Reply With Quote
Old 10-13-2017, 03:11 PM   #17
DanX
Human being with feelings
 
Join Date: Jan 2015
Posts: 2
Default

Thanks mitohund! That did the trick for me too.

I was using AirPods and whenever I would switch to the Reaper app, it would switch to 8khz audio. And when I would try switching to 44.1 in macOS Audio MIDI app, it would get forced back to 8khz.
DanX is offline   Reply With Quote
Old 10-13-2017, 05:06 PM   #18
ferropop
Human being with feelings
 
ferropop's Avatar
 
Join Date: Jan 2016
Posts: 187
Default

The actual solution here is using SoundFlower! Map everything through that and you don't have to do any tricks - just select SoundFlower as your audio device and done.
ferropop is offline   Reply With Quote
Old 10-13-2017, 05:43 PM   #19
serr
Human being with feelings
 
Join Date: Sep 2010
Posts: 6,438
Default

Quote:
Originally Posted by ferropop View Post
The actual solution here is using SoundFlower! Map everything through that and you don't have to do any tricks - just select SoundFlower as your audio device and done.
Yeah, that will work around most any situation.
__________________
Mac Pro 8x3.33GHz i7, 16GB, 256GB SSD(OS, apps), 3x2TB 7200 HD(data); MacBook Pro 2.8GHz, 6GB, 128GB SSD HD(OS, apps), 750GB 7200 HD(data); 2xTrue Precision 8; Apogee AD-16; 2xMOTU 828mk3, Evolution UC-33e; Faderport; WiRanger, iPad & the analog mixer has retired
serr is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:59 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.