Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 05-03-2016, 12:17 AM   #1
panicaftermath
Human being with feelings
 
Join Date: Dec 2014
Posts: 259
Default Glued MIDI items losing some text events (FIXED)

I have a number of MIDI items that contain text events along with notes. I want to glue these to a single item. When I do, some of the text events are getting lost.

In the licecap below, track 11 is a copy of track 10. After gluing, you can see that the text has been thinned out. Notes are all intact.

Anyone know why this might be happening?

panicaftermath is offline   Reply With Quote
Old 05-03-2016, 02:31 AM   #2
Dstruct
Human being with feelings
 
Dstruct's Avatar
 
Join Date: Jul 2006
Location: Dresden, Germany
Posts: 11,998
Default

Confirmed (5.18 x64)

MIDI item (4 bars) with 12 text events looses first 9 text events here after glueing.
Dstruct is offline   Reply With Quote
Old 05-03-2016, 01:40 PM   #3
panicaftermath
Human being with feelings
 
Join Date: Dec 2014
Posts: 259
Default

Thanks, Dstruct.
panicaftermath is offline   Reply With Quote
Old 05-17-2016, 02:16 PM   #4
panicaftermath
Human being with feelings
 
Join Date: Dec 2014
Posts: 259
Default

Still happening in 5.20 official. New licecap below. Track 10 is a copy of tack 9.

Very inconvenient (and a little dangerous.)

panicaftermath is offline   Reply With Quote
Old 05-17-2016, 02:28 PM   #5
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 10,241
Default

Having trouble duplicating, can you post the rpp?
Justin is online now   Reply With Quote
Old 05-17-2016, 02:48 PM   #6
panicaftermath
Human being with feelings
 
Join Date: Dec 2014
Posts: 259
Default

oops... thought I had. Here you go. Thanks


actually... hang on... wrong file.... removing.....

Last edited by panicaftermath; 05-17-2016 at 02:54 PM.
panicaftermath is offline   Reply With Quote
Old 05-17-2016, 02:54 PM   #7
panicaftermath
Human being with feelings
 
Join Date: Dec 2014
Posts: 259
Default

ok. those same items, copied to new test project.
Attached Files
File Type: rpp text loss bounce.RPP (21.5 KB, 34 views)
panicaftermath is offline   Reply With Quote
Old 05-18-2016, 06:00 AM   #8
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 9,174
Default

Fixing for the next build, thanks.
schwa is offline   Reply With Quote
Old 05-18-2016, 12:39 PM   #9
panicaftermath
Human being with feelings
 
Join Date: Dec 2014
Posts: 259
Default

Great. Thanks, schwa.
panicaftermath is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 06:39 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.