Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 10-09-2016, 02:57 PM   #1
daxliniere
Human being with feelings
 
daxliniere's Avatar
 
Join Date: Nov 2008
Location: London, UK
Posts: 1,619
Default Various large media source file problems (FIXED)

I'm having problems with large multichannel audio files in video files. To be clear, video is not being displayed. (Actually, I don't think REAPER can read the video stream of Apple ProRes 422 files, anyway.)

#1 - I imported an 89Gb .MOV file with 4 audio channels into REAPER. The waveform is drawn but if I set it to use only the first channel (Media Item Properties, Left only), the waveform disappears unless I zoom in horizontally.

#2 - Changing back to "Normal" (audio channels) in MIP forces a redraw of the waveforms.

#3 - After opening Sonnox SuprEsser (a heavy plugin), REAPER stops responding to keyboard commands and things like dragging plugin order, and tends to crash (even SuprEsser controls don't respond properly). When I attempted to update REAPER to 5.27pre1, the installer told me that reaper_wave.dll was still in use. (I had to wait a minute for it to be released.) Does that give you a hint as to what's gone wrong?

There are 3 possible causes that I can imagine: source is video file, source contains multichannel audio, or video file is HUGE. I'm inclined to think it's the last one, since it causes REAPER to run very slowly, with frequent freezes that don't interrupt playback (you can't press stop if you try).
__________________
Dax Liniere
5-room studio complex in London nearly finished!(videos)
[i7-4790K, 12Gb RAM, Win8.1x64, NVidia 9600, UAD2-OCTO, FireFaceUFX, REAPER x64]
daxliniere is offline   Reply With Quote
Old 10-09-2016, 04:34 PM   #2
daxliniere
Human being with feelings
 
daxliniere's Avatar
 
Join Date: Nov 2008
Location: London, UK
Posts: 1,619
Default

More details:
Zooming out makes waveform disappear:



Changing between multichannel and single channel shows different behaviour at different zoom levels:

__________________
Dax Liniere
5-room studio complex in London nearly finished!(videos)
[i7-4790K, 12Gb RAM, Win8.1x64, NVidia 9600, UAD2-OCTO, FireFaceUFX, REAPER x64]
daxliniere is offline   Reply With Quote
Old 10-10-2016, 07:46 AM   #3
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 10,482
Default

What decoder is it using? VLC? Does everything work perfectly throughout the whole file if you play the file in VLC?

If you have a similar type of media (same encoding, channel count) that isn't quite so long, does it work better? Can you post the media item source properties info?
Justin is offline   Reply With Quote
Old 10-10-2016, 08:44 AM   #4
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 10,482
Default

Quote:
Originally Posted by daxliniere View Post
#3 - After opening Sonnox SuprEsser (a heavy plugin), REAPER stops responding to keyboard commands and things like dragging plugin order, and tends to crash (even SuprEsser controls don't respond properly). When I attempted to update REAPER to 5.27pre1, the installer told me that reaper_wave.dll was still in use. (I had to wait a minute for it to be released.) Does that give you a hint as to what's gone wrong?
This sounds like it is probably the decoding for this file which is hanging. Finding out which decoder it is using will help, but it might just not be advisable to use this media with REAPER.

It might help to use the "no hi-res peaks" option, actually.

Please let me know what decoder mode it's using and what version of the decoder you're using (Media source properties, and the info from prefs/video/show decoder information).


I'm making myself a massive 70GB, 4 channel, 130 minute file now, to test with.

Last edited by Justin; 10-10-2016 at 09:10 AM.
Justin is offline   Reply With Quote
Old 10-10-2016, 11:52 AM   #5
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 10,482
Default

Quote:
#1 - I imported an 89Gb .MOV file with 4 audio channels into REAPER. The waveform is drawn but if I set it to use only the first channel (Media Item Properties, Left only), the waveform disappears unless I zoom in horizontally.
I've duplicated this, however it's only *while* building peaks. It appears then, if you encounter this, that your peaks are still being built. Is your peaks building window open (or was it disabled)? You can re-enable it in prefs/media.

This might also explain your "rebuild peaks action does nothing" note... if it's already (slowly) building the peaks...

BTW: It seems for these large files VLC might do a faster job than ffmpeg, not sure what you're using.
Justin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:41 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.