Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 10-23-2016, 04:06 PM   #1
tack
Human being with feelings
 
tack's Avatar
 
Join Date: Jan 2014
Posts: 270
Default [5.27] MIDI editor event list incorrectly parses LSB of bank select event (FIXED)

The MIDI event list incorrectly parses bank select events. The piano roll is correct, but the event list seems to be decoding the LSB incorrectly: it's always zero.

In this screen capture, I create a bank select event with MSB=1 LSB=1 with program 42. The piano roll correctly shows it as 1-1-42.

The event list however shows it as 1-0-42 and when opening the program select event properties via the event list, it incorrectly shows LSB=0.

Also occurs with 5.28pre2.


Last edited by tack; 10-23-2016 at 04:30 PM.
tack is offline   Reply With Quote
Old 10-23-2016, 06:42 PM   #2
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 9,174
Default

Fixing, thanks for the report.
schwa is offline   Reply With Quote
Old 10-23-2016, 06:47 PM   #3
tack
Human being with feelings
 
tack's Avatar
 
Join Date: Jan 2014
Posts: 270
Default

Quote:
Originally Posted by schwa View Post
Fixing, thanks for the report.
Thanks schwa!
tack is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 06:44 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.