Old 05-30-2017, 09:54 AM   #1
joshs
Human being with feelings
 
Join Date: Oct 2011
Posts: 41
Default Turning Snapping Completely Off

I'm finding it difficult to completely disable snapping! There are certain types of snapping that won't go away. When I'm trying to trim a recording (cursor on the edge of the item in the middle holding left click) the edge of the item will not move until I'm far enough away from an adjacent item or the beginning of the track. I've right clicked on the snap button and in that menu I unchecked absolutely everything. Is there something else that would be causing this behavior? If I hold "shift" this doesn't happen. I'm using v5.35 on Windows 7. Thanks!
joshs is offline   Reply With Quote
Old 05-30-2017, 10:01 AM   #2
andysarchus
Human being with feelings
 
andysarchus's Avatar
 
Join Date: Aug 2010
Location: A metropolitan bubble
Posts: 1,126
Default

Have you tried left-clicking on the snap button? This should turn snapping off completely.

-
__________________
"All the violence done to words is so vile that one can hardly bear to hear them any longer." - Adorno and Horkheimer
andysarchus is offline   Reply With Quote
Old 06-05-2017, 11:26 AM   #3
joshs
Human being with feelings
 
Join Date: Oct 2011
Posts: 41
Default

I absolutely did try that and it *should* turn it off completely. I'm not sure what's going on. Either it's a bug or I have some kind of weird setting engaged somewhere.
joshs is offline   Reply With Quote
Old 06-07-2017, 02:40 AM   #4
Ulf3000
Human being with feelings
 
Join Date: May 2016
Posts: 369
Default

hold shift while dragging , disables snapping for media-items and midi notes
Ulf3000 is offline   Reply With Quote
Old 06-23-2017, 09:06 PM   #5
joshs
Human being with feelings
 
Join Date: Oct 2011
Posts: 41
Default

I know and I mentioned that in my original post, but the question is, why do I have to hold shift when I've turned off snapping already?

Quote:
Originally Posted by Ulf3000 View Post
hold shift while dragging , disables snapping for media-items and midi notes
joshs is offline   Reply With Quote
Old 06-24-2017, 01:10 AM   #6
vanhaze
Human being with feelings
 
vanhaze's Avatar
 
Join Date: Jul 2012
Location: Netherlands
Posts: 5,247
Default

Quote:
Originally Posted by joshs View Post
I'm finding it difficult to completely disable snapping! There are certain types of snapping that won't go away. When I'm trying to trim a recording (cursor on the edge of the item in the middle holding left click) the edge of the item will not move until I'm far enough away from an adjacent item or the beginning of the track. I've right clicked on the snap button and in that menu I unchecked absolutely everything. Is there something else that would be causing this behavior? If I hold "shift" this doesn't happen. I'm using v5.35 on Windows 7. Thanks!
AFAIK, when you have snapping disabled by left clicking the Snap Toolbar button, so the button is in off-state , then ALL kinds of snapping should be turned off.

Seems to me it's some kind of bug on your system.
Personally i don't experience this bug on my system.
It's the same old and weird software story, that something in that software is not correctly working on 1 persons system, but IS working on another person's system.

Sorry to get offtopic .. :0/
Have you tried updating to latest beta version of Reaper and then see if you still experience your snap issue ?
__________________
Macbook Pro INTEL | Reaper, always latest version | OSX Ventura | Presonus Studio 24c
My Reaper Tips&Tricks YouTube Channel: https://www.youtube.com/user/vanhaze2000/playlists
vanhaze is offline   Reply With Quote
Old 10-24-2021, 12:45 PM   #7
explodingPSYCH
Human being with feelings
 
Join Date: Sep 2015
Posts: 302
Default

I'm having this same issue. Even when I have snapping completely turned off (using the magnet icon), dragging a media item edge will still snap unless I hold down shift.

Did you find any setting that was causing this? I was going to post on the bug forum, but after seeing how old this post is, I'm thinking it's not a bug. Or I guess not many people have run into this bug somehow?
explodingPSYCH is offline   Reply With Quote
Old 10-25-2021, 05:16 AM   #8
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 15,691
Default

Snapping media item edge edits to the source media length is not controlled by the snap settings dialog, so you do need to hold down the "ignoring snap" modifier to override it. I can see why this seems incorrect but given that there's no option to disable the source-media-length-snap in the snap settings dialog, this is a live-with-it for now.
schwa is offline   Reply With Quote
Old 10-26-2021, 05:14 PM   #9
explodingPSYCH
Human being with feelings
 
Join Date: Sep 2015
Posts: 302
Default

Quote:
Originally Posted by schwa View Post
Snapping media item edge edits to the source media length is not controlled by the snap settings dialog, so you do need to hold down the "ignoring snap" modifier to override it. I can see why this seems incorrect but given that there's no option to disable the source-media-length-snap in the snap settings dialog, this is a live-with-it for now.
Thanks for the reply! Could this be controlled with a checkbox in the snap settings, or possibly elsewhere like preferences?
explodingPSYCH is offline   Reply With Quote
Old 10-29-2021, 10:58 AM   #10
bolgwrad
Human being with feelings
 
bolgwrad's Avatar
 
Join Date: Mar 2011
Location: On my arse in Glasgow, Scotland
Posts: 1,990
Default

Right-clicking the snap icon gives you plenty of options for ignoring snap. I also have the mouse modifier 'Item: bottom half left drag' set to 'move item ignoring snap' so both options are available.
__________________
www.sachetsofrelish.com
bolgwrad is offline   Reply With Quote
Old 12-07-2021, 12:42 PM   #11
Buy One
Human being with feelings
 
Buy One's Avatar
 
Join Date: Sep 2019
Posts: 1,092
Default

Quote:
Originally Posted by schwa View Post
Snapping media item edge edits to the source media length is not controlled by the snap settings dialog, so you do need to hold down the "ignoring snap" modifier to override it. I can see why this seems incorrect but given that there's no option to disable the source-media-length-snap in the snap settings dialog, this is a live-with-it for now.
MIDI items don't have source AFAIK, yet left edge is still snapped to something when snapping is turned off and loop source is disabled. Or if it does have a source what kind of source is it?



When loop source is ON, the left edge is snapped to loop notch but past it moves smoothly.
__________________
https://github.com/Buy-One/REAPER-scripts (170)
REAPER is a DAW whose user guide file is larger than its installation file
Buy One is offline   Reply With Quote
Old 01-30-2022, 11:59 AM   #12
explodingPSYCH
Human being with feelings
 
Join Date: Sep 2015
Posts: 302
Default

Hi, it's been a few months so I wanted to check in on whether this is expected to be supported in Reaper:

Quote:
Originally Posted by schwa View Post
...given that there's no option to disable the source-media-length-snap in the snap settings dialog, this is a live-with-it for now.
explodingPSYCH is offline   Reply With Quote
Old 01-31-2022, 04:59 PM   #13
IDDQDSound
Human being with feelings
 
IDDQDSound's Avatar
 
Join Date: Jul 2019
Location: Vancouver, BC
Posts: 137
Default

I feel like I'm missing something given Schwa's comment, but would this not work:
In Mouse Modifiers>Media item>left drag
can you set the default to move item ignoring time selection and snap??

Alternatively you can set a cycle action in SWS:
Set default mouse modifier action for "Media item bottom half left drag" to "Move item ignoring time selection and snap"
---step---
Set default mouse modifier action for "Media item bottom half left drag" to "Move item ignoring time selection"

and engage it when needed and back to normal when not.
IDDQDSound is offline   Reply With Quote
Old 01-31-2022, 09:12 PM   #14
explodingPSYCH
Human being with feelings
 
Join Date: Sep 2015
Posts: 302
Default

Quote:
Originally Posted by IDDQDSound View Post
I feel like I'm missing something given Schwa's comment, but would this not work:
In Mouse Modifiers>Media item>left drag
can you set the default to move item ignoring time selection and snap??

Alternatively you can set a cycle action in SWS:
Set default mouse modifier action for "Media item bottom half left drag" to "Move item ignoring time selection and snap"
---step---
Set default mouse modifier action for "Media item bottom half left drag" to "Move item ignoring time selection"

and engage it when needed and back to normal when not.
I use shift click for Mouse Modifiers>Media item EDGE>left drag to ignore snap when dragging, as when snapping is globally on. However, this is just a work around. My understanding of turning off snapping globally is to remove the need for modifiers, etc that ignore the grid when snapping is on.

If I'm not mistaken your SWS solution would require turning off snapping, then activating the script as an extra step to fully turn off snapping. Seems more cumbersome than just using shift as I am now...

A more elegant solution would be to just make snapping actually effect everything that snaps to anything (in this case: media item edges and MIDI ITEM EDGES to their original lengths) But given Cockos' response to these kinds of bug reports, I'm not optimistic... :/
explodingPSYCH is offline   Reply With Quote
Old 01-18-2024, 02:11 AM   #15
audiocan
Human being with feelings
 
audiocan's Avatar
 
Join Date: Apr 2016
Posts: 122
Default

I'm also suffering from this. I would really like to have a "true" no-snapping feature without using a modifier. Much easier to do certain edits without getting carpal tunnel.
audiocan is offline   Reply With Quote
Old 01-21-2024, 09:53 AM   #16
MonkeyBars
Human being with feelings
 
MonkeyBars's Avatar
 
Join Date: Feb 2016
Location: Hollyweird
Posts: 2,600
Default

Implemented in v7.09+dev0120, thanks devs!!
MonkeyBars is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 05:28 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.