Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER for Linux

Reply
 
Thread Tools Display Modes
Old 08-22-2018, 09:59 AM   #521
4duhwinnn
Human being with feelings
 
Join Date: Mar 2017
Posts: 370
Default

There are a few nice plugins still with gui's that refuse to load,
I'm hoping the new gaming version will have the graphics magic
to overcome this. Serum engine seems running fine in the
Reaper alternate gui, would be nice to use it visually.
I actually had the 32 bit demo version fully appear in one setup,
but left it idle while using what I own, and things changed on
my end in the interim, over-rides, wine versions etc

Will be interesting to see if esync benefits Kontact users
desiring large projects!

Cheers
4duhwinnn is offline   Reply With Quote
Old 08-22-2018, 11:08 AM   #522
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,721
Default

I think esync will especially benefit people looking to use low latency.

Regarding plugins that don't display, most of them are probably due to incomplete d2d support. What is good is that Valve is working on DX10/11/12 support on vulkan, that ought to free up development time for code weavers to work on other stuff. It also seems to me that valve is gonna need working APIs for a lot of stuff that still isn't properly implemented. That can only be a good thing for us too
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is offline   Reply With Quote
Old 08-27-2018, 06:06 PM   #523
Glennbo
Human being with feelings
 
Glennbo's Avatar
 
Join Date: Mar 2008
Location: Planet Earth
Posts: 2,964
Default

Something I'm seeing on a real regular basis is when I add a new plugin using LinVST, the next time I launch REAPER, it always gets hung up at "Initializing", and I have to kill the process with the task manager. Then on the next launch everything is fine and the new plug will be there.

I did add three native U-He plugin instruments somewhere back, and it started doing this around that same time, but I don't know if that had anything to do with it, or just coincidence.
__________________
Glennbo
Hear My Music - Click Me!!!
--
Glennbo is offline   Reply With Quote
Old 08-27-2018, 06:20 PM   #524
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,721
Default

I do this in my script

Code:
wineserver -k
wineserver -p

reaper

wineserver -k
Maybe that helps?
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is offline   Reply With Quote
Old 08-27-2018, 06:31 PM   #525
Glennbo
Human being with feelings
 
Glennbo's Avatar
 
Join Date: Mar 2008
Location: Planet Earth
Posts: 2,964
Default

Quote:
Originally Posted by Jack Winter View Post
I do this in my script

Code:
wineserver -k
wineserver -p

reaper

wineserver -k
Maybe that helps?
I'll try that next time I add a plugin.

I have opened the task manager and watched it start up multiple instances of LinVST, which I assume is REAPER traversing all the plugins in the root of VSTPlugins. I also see two instances of Plug-n-Play get started that are highlighted in red on the task manager screen, but they close after a moment or two, where the LinVST instances all remain while stuck.

The next try REAPER will start and my new plugin will be there.
__________________
Glennbo
Hear My Music - Click Me!!!
--
Glennbo is offline   Reply With Quote
Old 08-28-2018, 12:40 AM   #526
osxmidi
Human being with feelings
 
Join Date: Feb 2014
Posts: 507
Default

Quote:
Originally Posted by Glennbo View Post
I'll try that next time I add a plugin.

I have opened the task manager and watched it start up multiple instances of LinVST, which I assume is REAPER traversing all the plugins in the root of VSTPlugins. I also see two instances of Plug-n-Play get started that are highlighted in red on the task manager screen, but they close after a moment or two, where the LinVST instances all remain while stuck.

The next try REAPER will start and my new plugin will be there.
Maybe look for any error messages that get displayed by starting Reaper from a Terminal.

The new LinVst 2.3 version has some more error reporting included in it.

Maybe try reinstalling some things, LinVst, Wine etc.

btw, unfortunately, each (new) version of LinVst needs to have all of the plugins name converted to be in sync with that LinVst version as well.

Last edited by osxmidi; 08-28-2018 at 12:56 AM.
osxmidi is offline   Reply With Quote
Old 08-28-2018, 01:47 AM   #527
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,721
Default

Quote:
Originally Posted by osxmidi View Post
btw, unfortunately, each (new) version of LinVst needs to have all of the plugins name converted to be in sync with that LinVst version as well.
Wouldn't it be a good idea to implement linvst as a vst shell?

It would know that the windows plugins didn't change (through it's own saved list), and reaper would rescan it when it sees that it has been updated. No more copying the .so to the same name as the .dll. You could even implement a single vst host on the wine side (for each prefix) that the linux side would establish connection to. Probably less overhead, and shorter load/scan times too.

In my above post regarding the wineserver I didn't really explain what the commands do.

"wineserver -p" preloads the wineserver and "wineserver -k" kills it.
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is offline   Reply With Quote
Old 08-28-2018, 05:29 AM   #528
osxmidi
Human being with feelings
 
Join Date: Feb 2014
Posts: 507
Default

Quote:
Originally Posted by Jack Winter View Post
Wouldn't it be a good idea to implement linvst as a vst shell?

It would know that the windows plugins didn't change (through it's own saved list), and reaper would rescan it when it sees that it has been updated. No more copying the .so to the same name as the .dll. You could even implement a single vst host on the wine side (for each prefix) that the linux side would establish connection to. Probably less overhead, and shorter load/scan times too.

In my above post regarding the wineserver I didn't really explain what the commands do.

"wineserver -p" preloads the wineserver and "wineserver -k" kills it.

Maybe it's something to think about.
osxmidi is offline   Reply With Quote
Old 08-28-2018, 06:08 AM   #529
net147
Human being with feelings
 
Join Date: Aug 2018
Posts: 17
Default

MT-PowerDrumKit has a neat feature where you can drag and drop MIDI drum grooves/fills from the VST into your DAW. Would be awesome if this worked in LinVST to drag and drop into native Reaper.
net147 is offline   Reply With Quote
Old 08-28-2018, 06:31 AM   #530
osxmidi
Human being with feelings
 
Join Date: Feb 2014
Posts: 507
Default

Quote:
Originally Posted by net147 View Post
MT-PowerDrumKit has a neat feature where you can drag and drop MIDI drum grooves/fills from the VST into your DAW. Would be awesome if this worked in LinVST to drag and drop into native Reaper.
LinVst accepts drag and drop into the plugin window from Linux but not between the plugin window and Linux Reaper.

There seems to be some sort of drag and drop workaround https://forum.cockos.com/showthread.php?t=210217
osxmidi is offline   Reply With Quote
Old 08-28-2018, 07:43 AM   #531
Glennbo
Human being with feelings
 
Glennbo's Avatar
 
Join Date: Mar 2008
Location: Planet Earth
Posts: 2,964
Default

Quote:
Originally Posted by osxmidi View Post
Maybe look for any error messages that get displayed by starting Reaper from a Terminal.

The new LinVst 2.3 version has some more error reporting included in it.

Maybe try reinstalling some things, LinVst, Wine etc.

btw, unfortunately, each (new) version of LinVst needs to have all of the plugins name converted to be in sync with that LinVst version as well.
Thanks, it looks like I'm running v2.2.5. If I were to update to 2.3, is that going to break the linkage to referenced plugins that have already been used in REAPER projects?

I was pleasantly surprised yesterday when I was forced to boot Windows over a stoopid calculator issue, and I decided to see what would happen if I loaded up the Windows version of REAPER and opened one of the projects that I've done in the Linux version. The first one I tried opened as if it were created in the Window version of REAPER. Not one single error or anything, and I'm running all 64-bit plugins in Windows, but 32-bit versions of the same plugins in LinVST.

The second project I opened barked about Kontakt not being able to find it's library, but that was expected because I'm running the full version of Kontakt on Windows and the Elements version in Linux, so they have different libraries. I was able to quickly point Kontakt to the full version library for each of the instruments used, and then that project played perfectly too.
__________________
Glennbo
Hear My Music - Click Me!!!
--
Glennbo is offline   Reply With Quote
Old 08-28-2018, 07:03 PM   #532
osxmidi
Human being with feelings
 
Join Date: Feb 2014
Posts: 507
Default

Quote:
Originally Posted by Glennbo View Post
Thanks, it looks like I'm running v2.2.5. If I were to update to 2.3, is that going to break the linkage to referenced plugins that have already been used in REAPER projects?

I was pleasantly surprised yesterday when I was forced to boot Windows over a stoopid calculator issue, and I decided to see what would happen if I loaded up the Windows version of REAPER and opened one of the projects that I've done in the Linux version. The first one I tried opened as if it were created in the Window version of REAPER. Not one single error or anything, and I'm running all 64-bit plugins in Windows, but 32-bit versions of the same plugins in LinVST.

The second project I opened barked about Kontakt not being able to find it's library, but that was expected because I'm running the full version of Kontakt on Windows and the Elements version in Linux, so they have different libraries. I was able to quickly point Kontakt to the full version library for each of the instruments used, and then that project played perfectly too.
The Reaper projects should be ok on Linux/Windows (maybe Mac) if the plugins are on the different platforms.

What happens with LinVst is that if the .so files (linvst.so) were from say version 2.2 but the server (lin-vst-server) was from version 2.3 then that might create some problems because the 2.3 .so files (linvst.so) are made to communicate with the 2.3 server (lin-vst-server).

For a new LinVst version just overwrite the lin-vst-server files in /usr/bin and then use linvstconvert to convert the old .so files to the new .so files (new linvst.so) and it should only take a few minutes.

Last edited by osxmidi; 08-28-2018 at 07:23 PM.
osxmidi is offline   Reply With Quote
Old 08-28-2018, 07:08 PM   #533
Glennbo
Human being with feelings
 
Glennbo's Avatar
 
Join Date: Mar 2008
Location: Planet Earth
Posts: 2,964
Default

Quote:
Originally Posted by osxmidi View Post
btw, unfortunately, each (new) version of LinVst needs to have all of the plugins name converted to be in sync with that LinVst version as well.
I replaced the version I was running with 2.3.1, then did a full mass convert of my whole C:\Program Files\VSTPlugins, and now loading my last test song, REAPER is trying to initialize, and I'm letting it try. I keep getting the following popup error about every 28 seconds. I assume that it's going to do that for every plugin I have in the VST folder? I'm letting it run to see if it will ever complete.



Edit:

After much too long, I gave up. Hand deleted all the .so files that got created by the "linvstconverttree" function, then tried starting REAPER again, and am getting the same repeating error every 28 seconds.
__________________
Glennbo
Hear My Music - Click Me!!!
--

Last edited by Glennbo; 10-22-2018 at 04:14 PM.
Glennbo is offline   Reply With Quote
Old 08-28-2018, 07:27 PM   #534
osxmidi
Human being with feelings
 
Join Date: Feb 2014
Posts: 507
Default

Quote:
Originally Posted by Glennbo View Post
I replaced the version I was running with 2.3.1, then did a full mass convert of my whole C:\Program Files\VSTPlugins, and now loading my last test song, REAPER is trying to initialize, and I'm letting it try. I keep getting the following popup error about every 28 seconds. I assume that it's going to do that for every plugin I have in the VST folder? I'm letting it run to see if it will ever complete.

That's a version mismatch error check that I added, so it seems that you have some sort of version mismatch.

Try copying/overwriting the 2.3.1 lin-vst-server files to /usr/bin and then to make sure run linvstconvert and pick the 2.3.1 version of linvst.so and then convert the dll names wherever they are.

linvstconvert should just overwrite any old .so file versions unless they are in a directory/folder that needs sudo permissions.

Any folder in the /home/user/.wine folder (including the Wine window tree folders ie the "Program Files" folder etc or any folder in /home/user (/home/user/.vst or /home/user/vst) should be ok and not need sudo permissions.

Personally, I keep all of my vst dll files in /home/user/vst and install them there unless the installer won't allow it and then they usually install somewhere in the .wine folder ie /home/user/.wine/drive_c/"Program Files"/VSTPlugins or something like that.

If the dll plugin files are in a sudo permission folder such as /usr/lib/vst, then make a user permission folder such as /home/user/vst and then make symbolic links to /usr/lib/vst in the /home/user/vst folder by changing into /home/user/vst and running ln -s /usr/lib/vst/* . and then run linvstconvert on the /home/user/vst folder and then set the DAW to search the /home/user/vst folder.

linvstconvert can also be run with sudo permission for folders/directories that need sudo permission.

Last edited by osxmidi; 08-29-2018 at 04:17 AM.
osxmidi is offline   Reply With Quote
Old 08-28-2018, 07:45 PM   #535
Glennbo
Human being with feelings
 
Glennbo's Avatar
 
Join Date: Mar 2008
Location: Planet Earth
Posts: 2,964
Default

Quote:
Originally Posted by osxmidi View Post
That's a version mismatch error that I added, so it seems that you have some sort of version mismatch.

Try copying/overwriting the 2.3.1 lin-vst-server files to /usr/bin and then to make sure run linvstconvert and pick the 2.3.1 version of linvst.so and then convert the dll names wherever they are.

linvstconvert should just overwrite any old .so file versions unless they are in a directory/folder that needs sudo permissions.

Any folder in the /home/user/.wine folder (including the Wine window tree folders ie the "Program Files" folder etc or any folder in /home/user should be ok and not need sudo permissions.

If a vst dll is in a directory/folder that needs sudo permissions, then a symbolic link can be used.
That was it. I forgot to do that step. Thanks! Also, it did run through the entire initialization of REAPER and not get hung up this time. I did get two errors saying something to the effect of "process replacement not supported" or something like that for two old "Frühere" plugins that I still like, but they seem to work exactly like they did before doing the update.

Perhaps that message has something to do with the cursor disappearing when over those plugins? I have to kind of guesstimate where the cursor is, but then I can dial the knobs on their interfaces once I am invisibly over them.
__________________
Glennbo
Hear My Music - Click Me!!!
--
Glennbo is offline   Reply With Quote
Old 09-04-2018, 03:29 PM   #536
Lokasenna
Human being with feelings
 
Lokasenna's Avatar
 
Join Date: Sep 2008
Location: The vast, frozen wasteland of western Canadia.
Posts: 5,641
Default

Quote:
Originally Posted by osxmidi View Post
LinVst accepts drag and drop into the plugin window from Linux but not between the plugin window and Linux Reaper.

There seems to be some sort of drag and drop workaround https://forum.cockos.com/showthread.php?t=210217
Updated script for this, should work with any plugin: https://forum.cockos.com/showthread.php?p=2030985
Lokasenna is offline   Reply With Quote
Old 09-04-2018, 07:16 PM   #537
osxmidi
Human being with feelings
 
Join Date: Feb 2014
Posts: 507
Default

Quote:
Originally Posted by Lokasenna View Post
Updated script for this, should work with any plugin: https://forum.cockos.com/showthread.php?p=2030985
Very good.
osxmidi is offline   Reply With Quote
Old 09-04-2018, 07:18 PM   #538
osxmidi
Human being with feelings
 
Join Date: Feb 2014
Posts: 507
Default

Waves Central works again with Wine Staging 3.15.

It doesn't work with Wine Staging 3.12 3.13 or 3.14
osxmidi is offline   Reply With Quote
Old 09-06-2018, 10:36 AM   #539
vitaminx
Human being with feelings
 
vitaminx's Avatar
 
Join Date: Jul 2018
Location: Barcelona, Spain
Posts: 42
Default

Hi everyone,

I tried to install "Addictive Keys" and "Novaton Bass Station" (the first version) with Carla and when scanning the plugins I get:

"The program carla-discovery-win32.exe has encountered a serious problem and needs to close"

But I have many other Windows VSTs, both 32 and 64 working correctly.

I got carla from the kxstudio repository, which also install wine-rt.
I didn't change anything in wincfg settings.


Could someone please help me to get the plugins running?

Thanks

*EDIT* The standalone "Addictive Keys" exe works by the way, but not the VST with Carla.
__________________
Soundcloud
vitaminx is offline   Reply With Quote
Old 09-06-2018, 10:35 PM   #540
DPP2018
Human being with feelings
 
Join Date: Sep 2018
Posts: 5
Default

Hello everyone,

I am an non native English speaker - so at first sorry for my English. At the moment I am evaluating Reaper for Linux with all my (Windows) plugins. Big big thanks to Cockos for the Linuxport and big big thanks to osxmidi for linvst. It makes it so easy to use Windows VSTs.

I installed Waves Central with Wine Staging 3.15 and installed my plugins from Waves (Grand Rhapsody (VSTi) and some plugins - eqs, comp, limiter, revs and some other). All work now flawless - I can play the Grand in realtime as VST-Plugin in Reaper. The standalone doesent work. I use a very old Alesis IO/2 at a Ryzen 1700@3,7 GHz on Lubuntu 18.04 with lowlatency kernel and the usual rt audio tweaks. In Jack I use a buffer 128/2 with 48kHz. I use stuff from IK Multimedia too (eg Sampletank3 in realtime). Native Instruments Kontakt Player runs with 3.15 dev but not with staging. I use now no overrides in wine.

At first it was a hazzle to run the Waves Stuff. Installation without problems, but I get every time a LinVST-error (Error getting instance WaveShell1-Vst10.0_x64.dll). I tried a lot and finally I had a .wine that works. I cant say why (tried some wintricks vcrun2015, winetricks install dlls, some manual dll copying). I tried to reproduce but had no luck. I followed every guide for that (robocopy, reg hacks, dll overrieds) but no luck.

But now I am happy - all stuff is up and running (with better performance that i would have expected). I backed up my .wine and the wine3.15 dpkgs in case that something breaks in the future .

Just a quick impression so far - now I have to play a little more with my Installations .

Edit: License managing in Waves Central works for me. Add license from cloud to drive and vice versa was no problem. Didnt tried it via USB so far.

Edit2: Maybe it is interesting: I tried shell2vst to run the standanlone waves plugins, but get in the faulty .wines the same error as with the waves shell.

Last edited by DPP2018; 09-06-2018 at 10:46 PM.
DPP2018 is offline   Reply With Quote
Old 09-07-2018, 12:02 AM   #541
DPP2018
Human being with feelings
 
Join Date: Sep 2018
Posts: 5
Default

Quote:
Originally Posted by Jack Winter View Post
I think esync will especially benefit people looking to use low latency.
I am eager to try this esync stuff. I googled and found a esync-patched wine-staging-3.15 version via lutris (https://github.com/lutris/lutris/wiki/How-to:-Esync).

Jack, would it be enough to download this version, copy it to the folder under /opt and link all /usr/bin/wine* links there? Before I start reaper than I would do an "export WINEESYNC=1".

Would esync be used than for all wine-instances for plugins via linvst? How can I test if esync is in use?
DPP2018 is offline   Reply With Quote
Old 09-07-2018, 03:09 AM   #542
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,721
Default

To be honest I don't know I think you can install it in /opt and run it out of /opt, while still keeping your regular wine install, but am not sure about this. I know that I've built wine myself and then ran it out of the build directories without installing it, and that this works perfectly fine.

How to know if it's activated I'm also not sure about. FWIW, I did some quick tests and to me it appeared exactly the same as reaper/linvst with regular wine, but it's possible that I messed something up

If you figure it out, then please let me know!
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is offline   Reply With Quote
Old 09-07-2018, 04:17 AM   #543
DPP2018
Human being with feelings
 
Join Date: Sep 2018
Posts: 5
Default

Hi Jack, I play a little around with this stuff. Finally I downloaded a esync-patched winestaging 3.15 via lutris, backuped my working /opt/wine and copied the patched esync wine in my /opt/wine (wanna avoid inconsitency with pathes and wine-envs).

The WINEESYNC I put in my .bashrc via export WINEESYNC=1. Additionally I put there a export DXVK=fps and started a Program which uses DX11 via DXVK - I got an HUD-Display so it seems to work.

I assume that its the same with WINEESYNC=1. I tested with a saved Reaper Project - Grand Rhapsody (its a CPU-hog, not comparable to Pianoteq native :P) with some EQs, Limiter, Compressor, Con-Reverb in the channel as inserts.

Hard to judge - I played with damper pedal down the whole keyboard to get the max polyphony. With Esync=1 it seems that the RT CPU (I assume I have to look for this in the perf graph and not the percent in channel because it runs via linvst and outside reaper) is about 0,5-1 percent less (from around 17,7 / 17,9 down to 16,9 / 17,4). So it seems to benefit a little. At the moment I havent a big project, I am still do testing. Maybe I can play a little more on the weekend.

Thanks for all this nice work and help. Anyway it runs better as I expected.

ps: the esync-patched wine is staging - so as mentioned before no Kontakt

edit typos
DPP2018 is offline   Reply With Quote
Old 09-07-2018, 05:25 AM   #544
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,721
Default

Maybe check the cpu use of wineserver too. I'd imagine it to be lower with the esync patch.

If you can build from source, you can also try: https://github.com/ValveSoftware/Proton
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is offline   Reply With Quote
Old 09-07-2018, 10:57 PM   #545
DPP2018
Human being with feelings
 
Join Date: Sep 2018
Posts: 5
Default

Hi Jack, yes I could compile my own wine but I dont like :P Dependencies, dev libraries 32/64 compile and so on ... didnt it for a long time. I I think that the Proton source base on wine 3.02.

I did some more testings - I played only the native Pianoteq Steinway D Prelude as PlugIn in Reaper: the RT longest block counts to whole time between 0.30 and 0.40 ms from allowed 2.67 ms. I downloaded the Windows trial version and run the same Steinway D via linvst/wine. The RT longest block counts to whole time between 0.80 and 1.20 ms from allowed 2.67 ms. So with not so heavy load playing its ok.

I played than some fast a-moll arpeggios with pedal so that Pianoteq uses around 60 voices: the native version RT longest block counts was between .30 and .40 ms. The windows version jumps up to over 2.67 ms and xruns. The RT CPU jumped at over 70%.

Just for info.
DPP2018 is offline   Reply With Quote
Old 09-08-2018, 05:35 AM   #546
korakios
Human being with feelings
 
Join Date: Feb 2011
Location: Greece
Posts: 98
Default

Quote:
Originally Posted by DPP2018 View Post
Hi Jack, yes I could compile my own wine but I dont like :P Dependencies, dev libraries 32/64 compile and so on ... didnt it for a long time. I I think that the Proton source base on wine 3.02.

I did some more testings - I played only the native Pianoteq Steinway D Prelude as PlugIn in Reaper: the RT longest block counts to whole time between 0.30 and 0.40 ms from allowed 2.67 ms. I downloaded the Windows trial version and run the same Steinway D via linvst/wine. The RT longest block counts to whole time between 0.80 and 1.20 ms from allowed 2.67 ms. So with not so heavy load playing its ok.

I played than some fast a-moll arpeggios with pedal so that Pianoteq uses around 60 voices: the native version RT longest block counts was between .30 and .40 ms. The windows version jumps up to over 2.67 ms and xruns. The RT CPU jumped at over 70%.

Just for info.
My main problem is that on most windows vsts I have some xruns on 64 buffer size (and can’t go lower)
Does esync patch helps on small buffers ?
Sorry if you already answered that (didnt understood exactly the term “RT longest block count”)
__________________
No midi clock sync ? How about Ableton Link?
korakios is offline   Reply With Quote
Old 09-08-2018, 06:23 AM   #547
UlrichH
Human being with feelings
 
Join Date: Aug 2017
Posts: 14
Default

DXVK saved Serum for me, without it installed and activated the plugin would not draw correctly
UlrichH is offline   Reply With Quote
Old 09-11-2018, 06:05 AM   #548
DPP2018
Human being with feelings
 
Join Date: Sep 2018
Posts: 5
Default

Quote:
Originally Posted by korakios View Post
My main problem is that on most windows vsts I have some xruns on 64 buffer size (and can’t go lower)
Does esync patch helps on small buffers ?
Sorry if you already answered that (didnt understood exactly the term “RT longest block count”)
I work with 128 Samples, 2 periods. Reaper as VST-Host is than granted 2,67 ms for calculation to fill this puffer in time (48000 samples per second (my samplingrate) divided by 128 sampler = 2,67 ms). In Reaper is in the performance window the longest block count - this is an average value over the last seconds that Reaper needs to calculate the actual plugin-load. If Reaper needs longer than this mentioned 2,67ms in my case I get xruns.

Maybe I could lower this value to 1,33 ms (puffer 64 samples) but I dont want to avoid xruns. We talk here for the pure time for calculation. Think the whole chain. My stagepiano sends a midi-event to my USB-to-Midi-Interface - first millisecond. The Kernel needs to look periodically into the puffer from the USB-Insterfaces if there are events. Some more milliseconds. This collected events have to go to Reaper, which needs to calculate (in my case) in 2,67 ms all audio-output-data. This 128 sample puffer goes to the USB-Audio-Interface - some more millisecond. Now I play with headphones and hear the sound. Maybe 10 milliseconds after I pressed the key - feels nice. Now I wanna play via my monitors, they are in a nice triangle about 1 meter away from my ears - ouch another 3 milliseconds delay for the transmission via air. Now its 13 milliseconds. For _me_ its not such a big deal if I lower 2,67 to 1,33 or so. I feel the latency at 256 samples and above (5,3 ms). There are people who plays with 512 samples puffer. In case you wanna monitor your recordings through Reapers its a bigger impact maybe for a singer. For lowlatency-playback of an VSTi sit 30 cm nearer to your monitor - you save 1 ms latency :P Imagine a real concert grand sized piano where the player sits more than 3 meters away from the farest point of the soundboard - 10 ms latency for the audio-air-transmission - just to put the separate latencies in relation.

I cant go lower with my Alesis IO2 than 64 ms. The Jackserver dont acceppt - dont know why but like I said not important for me.

I cant judge the impact of esync at the moment. I hope I can do some more testing the next days.
DPP2018 is offline   Reply With Quote
Old 09-12-2018, 11:49 AM   #549
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,721
Default

My experience is that it works fine for mixing on larger buffers but is dropout prone on lower buffer sizes. But consider it a miracle anyways, we are trying to run plugins written for a different OS after all...

Hopefully things can be improved and I'm sure that they will be.

I still have to make a good evaluation of esync, but theoretically it ought to help, maybe there are still other bottlenecks.
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is offline   Reply With Quote
Old 09-12-2018, 12:33 PM   #550
Glennbo
Human being with feelings
 
Glennbo's Avatar
 
Join Date: Mar 2008
Location: Planet Earth
Posts: 2,964
Default

Quote:
Originally Posted by Jack Winter View Post
My experience is that it works fine for mixing on larger buffers but is dropout prone on lower buffer sizes. But consider it a miracle anyways, we are trying to run plugins written for a different OS after all...

Hopefully things can be improved and I'm sure that they will be.

I still have to make a good evaluation of esync, but theoretically it ought to help, maybe there are still other bottlenecks.
I keep having to stop myself from posting to the thread on the main group asking what features we'd like to see in REAPER 6. Native VST/VSTi bridging in Linux, is what I'd add. Let me install my plugin in WINE, and if that goes OK, then REAPER sees it and adds it on the next startup.
__________________
Glennbo
Hear My Music - Click Me!!!
--
Glennbo is offline   Reply With Quote
Old 09-13-2018, 09:17 AM   #551
UlrichH
Human being with feelings
 
Join Date: Aug 2017
Posts: 14
Default

Quote:
Native VST/VSTi bridging in Linux, is what I'd add. Let me install my plugin in WINE, and if that goes OK, then REAPER sees it and adds it on the next startup.
Steam made it happen, why not Cockos ?
UlrichH is offline   Reply With Quote
Old 09-15-2018, 10:39 AM   #552
Klangfarben
Human being with feelings
 
Join Date: Jul 2016
Posts: 347
Default

Has anyone managed to get Acustica Aquarius working under wine? I'm able to install Aquarius, log in to my account and see all my plugins. However, when I go to install something, I get a "download failed" message every time.

Tried different versions of Aquarius, including the latest. Tried changing directories from the .wine folder to home/user but same result.

Has anyone successfully used Aquarius or managed to install Aqua plugins and/or Nebula? I'm using Wine Staging 3.15 in Manjaro/KDE.
Klangfarben is offline   Reply With Quote
Old 09-16-2018, 03:45 PM   #553
Ryan_Shaw
Human being with feelings
 
Join Date: Nov 2016
Posts: 4
Exclamation lin-vst-servervst not found or linVSt version mismatch

Hi everyone,

I'm not sure if it's appropriate to ask for help in this thread,

I'm running Mint 19 Cinnamon.

I've followed the steps to use lin-vst, but when I set the folder location for the VST locstion and press scan, I end I recieve this error message;

lin-vst-servervst not found or linVSt version mismatch

Can anyone point me in the right direction, am I using an incompatible distro?

Many thanks,

Ryan
Ryan_Shaw is offline   Reply With Quote
Old 09-16-2018, 03:56 PM   #554
Glennbo
Human being with feelings
 
Glennbo's Avatar
 
Join Date: Mar 2008
Location: Planet Earth
Posts: 2,964
Default

Quote:
Originally Posted by Ryan_Shaw View Post
Hi everyone,

I'm not sure if it's appropriate to ask for help in this thread,

I'm running Mint 19 Cinnamon.

I've followed the steps to use lin-vst, but when I set the folder location for the VST locstion and press scan, I end I recieve this error message;

lin-vst-servervst not found or linVSt version mismatch

Can anyone point me in the right direction, am I using an incompatible distro?

Many thanks,

Ryan
I got that after upgrading LinVST because I forgot to copy the four files with "lin-vst-server" in their names to the /usr/bin/ folder. After doing that, everything was cool again.
__________________
Glennbo
Hear My Music - Click Me!!!
--
Glennbo is offline   Reply With Quote
Old 09-16-2018, 04:09 PM   #555
Ryan_Shaw
Human being with feelings
 
Join Date: Nov 2016
Posts: 4
Default

Quote:
Originally Posted by Glennbo View Post
I got that after upgrading LinVST because I forgot to copy the four files with "lin-vst-server" in their names to the /usr/bin/ folder. After doing that, everything was cool again.
I have already copied those files into /usr/bin/ - Just double checked that they are there also,

Cheers man, any other suggestions?
Ryan_Shaw is offline   Reply With Quote
Old 09-16-2018, 05:01 PM   #556
Glennbo
Human being with feelings
 
Glennbo's Avatar
 
Join Date: Mar 2008
Location: Planet Earth
Posts: 2,964
Default

Quote:
Originally Posted by Ryan_Shaw View Post
I have already copied those files into /usr/bin/ - Just double checked that they are there also,

Cheers man, any other suggestions?
Did you also re-run linvstconvert on all your plugins so they would match?
__________________
Glennbo
Hear My Music - Click Me!!!
--
Glennbo is offline   Reply With Quote
Old 09-18-2018, 03:21 AM   #557
RyanJamesShaw
Human being with feelings
 
Join Date: Feb 2016
Posts: 2
Default

Quote:
Originally Posted by Glennbo View Post
Did you also re-run linvstconvert on all your plugins so they would match?
Yea, I only have one dll in the folder at the moment, I’ve ran the linconvert a couple of times, still no joy
RyanJamesShaw is offline   Reply With Quote
Old 09-18-2018, 06:50 AM   #558
osxmidi
Human being with feelings
 
Join Date: Feb 2014
Posts: 507
Default

Quote:
Originally Posted by RyanJamesShaw View Post
Yea, I only have one dll in the folder at the moment, I’ve ran the linconvert a couple of times, still no joy
If an older version of linvst.so is used in linvstconvert then there would be a version mismatch.

If /usr/bin/lin-vst-server.exe and /usr/bin/lin-vst-server.exe.so are from an older version then there would be a version mismatch.

If /usr/bin/lin-vst-server.exe or /usr/bin/lin-vst-server.exe.so are missing then that would also produce an error.

Usually

sudo cp /path to LinVst newer version folder/lin-vst-server.exe /usr/bin

sudo cp /path to LinVst newer version folder/lin-vst-server.exe.so /usr/bin

and using linvstconvert on the windows vst file folder using the newer version linvst.so would do it.



If there was an older version of LinVst hanging around and it's not getting overwritten for some reason then to delete the older version and install the newer version and making sure the older version is deleted,

sudo rm /usr/bin/lin-vst-server.exe

sudo rm /usr/bin/lin-vst-server.exe.so

sudo cp /path to LinVst newer version folder/lin-vst-server.exe /usr/bin

sudo cp /path to LinVst newer version folder/lin-vst-server.exe.so /usr/bin

cd /windows vst file folder

rm *.so (btw it will also delete Linux vst .so files if any are in the folder)

use linvstconvert on the windows vst file folder using the newer version linvst.so

Last edited by osxmidi; 09-18-2018 at 07:00 AM.
osxmidi is offline   Reply With Quote
Old 09-18-2018, 10:08 AM   #559
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,721
Default

Can't you get the "lin-vst-servervst not found or linVSt version mismatch" after a timeout too? I think I've seen that happen when it's taken a long time to scan for instance a vst shell.
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is offline   Reply With Quote
Old 09-18-2018, 07:13 PM   #560
osxmidi
Human being with feelings
 
Join Date: Feb 2014
Posts: 507
Default

Quote:
Originally Posted by Jack Winter View Post
Can't you get the "lin-vst-servervst not found or linVSt version mismatch" after a timeout too? I think I've seen that happen when it's taken a long time to scan for instance a vst shell.
It could happen.

There is a 20 second connect timeout, so if for some reason (maybe a vst having load problems, dll's etc) a connection can't be made then an error happens.

Wine on initial start can take a while to load all of it's plumbing, so on older systems (especially with slow hard disks) I tend to run winecfg first which preloads the wine plumbing and then wine loads faster after that.
osxmidi is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 06:15 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.