Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 09-20-2017, 04:24 PM   #1
SonicAxiom
Human being with feelings
 
SonicAxiom's Avatar
 
Join Date: Dec 2012
Location: Germany
Posts: 2,154
Default bug rendering video zooming with parameter modulation

I've set up parameter modulation to facilitate video-in-video. I automated the zoom parameter of the video plugin and linked it to the x and y offset parameters so that when I automate zooming (out) of the video, it will not only decrease in size but will also drift to the left of the screen to make place for the other video. This is much more convenient than to manually automate x/y offset.

I used another instance of the same zooming plugin and inverted the parameter modulation of the x parameter to make the video shrink to the other (right) edge of the screen.

The parameter modulations work, however, when I render the project, x and y parameter modulations are ignored. They also seem to get ignored from time to time while working on the project.



SonicAxiom is offline   Reply With Quote
Old 12-21-2018, 03:38 AM   #2
Eliseat
Human being with feelings
 
Eliseat's Avatar
 
Join Date: Mar 2018
Location: Cologne
Posts: 1,318
Default

Though this is an amazing idea, its practically unusable as zooming and panning at the same time produces such a rough motion. I recreated your setup and the video image jumps around like crazy until it finds its corner.

It shows once more that there is something wrong with the zoom parameter.

Eliseat is offline   Reply With Quote
Old 12-21-2018, 08:51 AM   #3
SonicAxiom
Human being with feelings
 
SonicAxiom's Avatar
 
Join Date: Dec 2012
Location: Germany
Posts: 2,154
Default

yes, I also liked the idea but sadly it doesn't currently work.

Also, something seems to be broken in recent Reaper versions. Using v5.962 or even a newer dev build I can't even replicate my own setup shown in the original licecap. When I automate the x-offset parameter of the zoom/pan preset I cannot get the zoom parameter to be modulated by the x-offset. Regarding the flickering, I'm not sure if that was an issue when I posted this bug report. I only payed attention to the parameter modulation not being rendered and my licecaps are always set to only 5fps.

As a sidenote, I'm also perceiving image zooming that is not as smooth as it should be (currently being discussed in another thread). I see so many amateur videos/photo slide shows where zomming/panning of images is absolutely smooth. Unfortunatlely, I never managed it to get the same smooth results in Reaper.

.
__________________
[Check out my free VST plugin collection here.]
SonicAxiom is offline   Reply With Quote
Old 12-21-2018, 09:35 AM   #4
SonicAxiom
Human being with feelings
 
SonicAxiom's Avatar
 
Join Date: Dec 2012
Location: Germany
Posts: 2,154
Default

I'm now getting a lot of flickering, too, and also a lot of lag. In the following example, I'm automating the x-offset parameter and this one then parameter modulates both the zoom parameter and the y-offset parameter. These lag behind considerably and rendering to a file still doesn't work properly either.



.
__________________
[Check out my free VST plugin collection here.]
SonicAxiom is offline   Reply With Quote
Old 12-21-2018, 05:11 PM   #5
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,948
Default

Yeah parameter modulation is not really supported for video processors (yet).
Justin is offline   Reply With Quote
Old 12-21-2018, 05:25 PM   #6
SonicAxiom
Human being with feelings
 
SonicAxiom's Avatar
 
Join Date: Dec 2012
Location: Germany
Posts: 2,154
Default

Quote:
Originally Posted by Justin View Post
Yeah parameter modulation is not really supported for video processors (yet).
thanks for the info. Would be great to have it
Can help automating several video parameters with a single envelope.
Hope you'll also find a way to improve image/text zooming smoothness.

.
__________________
[Check out my free VST plugin collection here.]

Last edited by SonicAxiom; 12-21-2018 at 08:18 PM.
SonicAxiom is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:47 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.