Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 09-30-2017, 06:32 AM   #1
PitchSlap
Human being with feelings
 
PitchSlap's Avatar
 
Join Date: Jan 2008
Location: Vancouver, BC
Posts: 3,136
Default Ogg Opus .ogg files (YouTube etc.) won't load unless renamed to .opus (FIXED)

I've been having issues with audio extracted from YouTube videos not playing in Reaper even though they are a supported format.

Thanks to some help from the fine folks in the JDownloader support chatroom I figured out it's because Reaper will only open .ogg files that are encoded with Ogg Vorbis.

Ogg Opus is supported, but only if the file is (re)named .opus

Now that I know the problem, it's trivial to rename the files (yay, no more dodgy transcoding), but ideally Reaper should check the actual encoding, not just the container extension before deciding if it supports a file (this stuff is too arcane for the average person just trying to make music).


I remember having similar issues years ago needing to rename other file extensions for Reaper to recognize them (.mp4 I think), so it's not .ogg specific.


Thanks in advance if you get time to fix this.
__________________
FRs: v5 Media Explorer Requests, Global Quantization, Session View
Win10 64-bit, Reaper 5(x64), Core i7-5700HQ, 16GB RAM, GeForce GTX 960M, SSD
PitchSlap is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 06:33 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.