Old 10-14-2017, 02:16 PM   #1
underswamp
Human being with feelings
 
Join Date: Sep 2014
Posts: 10
Default MIDI notes just...disappearing

It's that simple. random notes interspersed throughout the entire composition just seem to disappear. I was doing damage control for a while, but there's just no fixing it. Sometimes it's single notes, other times entire items are empty. They just keep going. Am I doing something wrong? Seriously considering switching DAWs over this.


Just re-listened to the entire track and there are soooo many notes gone. It's my own composition, I know every note and every note's place, I could go back in and rewrite it if I had to, but one, they'll just keep disappearing, and two, and more importantly, I should never have to do this. Ever. This is so bizarre. It's infuriating. Please help if you can.
underswamp is offline   Reply With Quote
Old 10-14-2017, 02:21 PM   #2
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 19,578
Default

I've never had something like that happen in Reaper...
EvilDragon is online now   Reply With Quote
Old 10-14-2017, 02:28 PM   #3
uncleswede
Human being with feelings
 
Join Date: Feb 2015
Posts: 438
Default

Have you checked the MIDI event view to see if the "missing" notes are visible there?
uncleswede is online now   Reply With Quote
Old 10-14-2017, 03:31 PM   #4
underswamp
Human being with feelings
 
Join Date: Sep 2014
Posts: 10
Default

Quote:
Originally Posted by uncleswede View Post
Have you checked the MIDI event view to see if the "missing" notes are visible there?
Is that where you press E on the item?
underswamp is offline   Reply With Quote
Old 10-14-2017, 03:52 PM   #5
uncleswede
Human being with feelings
 
Join Date: Feb 2015
Posts: 438
Default

No... dbl-click a MIDI item to get into the MIDI Editor then press Alt-3
uncleswede is online now   Reply With Quote
Old 11-04-2017, 01:46 AM   #6
ivansc
Human being with feelings
 
Join Date: Aug 2007
Location: Near Cambridge UK and Near Questembert, France
Posts: 15,989
Default

Noticed you had started a second thread, but hadn't updated this to tell us what your progress was.

So. To get back to your initial post, could you tell us a bit about what equipment you are using (what keyboard, etc) and what your computer setup consists of, including cpu, amount of ram, what OS - including version - and most importantly, what Audio/MIDI interface you are using & what drivers?
Hopefully ASIO.

Next step is to download and run resplendence dot com's latency checker while you have reaper running.
The results of all this will at least give us a baseline to work from.

Without really having much to go on, it rather sounds like you have something going on between your keyboard, interface & Reaper in terms of buffer overflow.
__________________
UK and USA: Our leaders MAY be buffoons but they are still dangerous buffoons.
ivansc is online now   Reply With Quote
Old 11-04-2017, 03:07 AM   #7
juliansader
Human being with feelings
 
Join Date: Jul 2009
Posts: 1,258
Default

What exactly do you mean by "random notes interspersed throughout the entire composition just seem to disappear"?

* How did you input the notes? By recording from a MIDI keyboard, or by drawing in the MIDI editor?

* Did the notes exist for a while before suddenly disappearing, or are you recording the notes live, and some notes never got recorded?
juliansader is online now   Reply With Quote
Old 11-04-2017, 11:02 AM   #8
grinder
Human being with feelings
 
grinder's Avatar
 
Join Date: Jan 2009
Location: New Zealand
Posts: 1,559
Default

Are you saving your work?
Before you start thinking Reaper does this because it has singled you out, this as has been said by EvilDragon is a unheard of happening. Is there anyone out there that has heard of this happening before?
This may be a new happening that said underswamp you should simmer down and let the techs into your world for a while.

Grinder
grinder is offline   Reply With Quote
Old 11-04-2017, 04:28 PM   #9
underswamp
Human being with feelings
 
Join Date: Sep 2014
Posts: 10
Default

Quote:
Originally Posted by ivansc View Post
Noticed you had started a second thread, but hadn't updated this to tell us what your progress was.

So. To get back to your initial post, could you tell us a bit about what equipment you are using (what keyboard, etc) and what your computer setup consists of, including cpu, amount of ram, what OS - including version - and most importantly, what Audio/MIDI interface you are using & what drivers?
Hopefully ASIO.

Next step is to download and run resplendence dot com's latency checker while you have reaper running.
The results of all this will at least give us a baseline to work from.

Without really having much to go on, it rather sounds like you have something going on between your keyboard, interface & Reaper in terms of buffer overflow.
Hi, thanks. I'm using a Lenovo Thinkpad, and I'm writing in all the notes at all times, never using a MIDI keyboard. I run an i5 processor with 4GBs of ram and Windows 7. I don't use an interface currently, but my audio driver is currently set to "Waveout"; I can easily switch to ASIO. I think I was getting underruns (probably due to 4GB ran) and so I switched it since I'm not recording any audio.

I got the following error:

Service Unavailable

HTTP Error 503. The service is unavailable.

at http://www.resplendence.com/ but will try again later. Thanks for your help. I like Reaper and don't want to switch, but this is obviously a deal breaker if it can't be fixed. Thanks again.
underswamp is offline   Reply With Quote
Old 11-04-2017, 04:30 PM   #10
underswamp
Human being with feelings
 
Join Date: Sep 2014
Posts: 10
Default

Quote:
Originally Posted by juliansader View Post
What exactly do you mean by "random notes interspersed throughout the entire composition just seem to disappear"?

* How did you input the notes? By recording from a MIDI keyboard, or by drawing in the MIDI editor?

* Did the notes exist for a while before suddenly disappearing, or are you recording the notes live, and some notes never got recorded?
I mean in MIDI items from up to the beginning of the track that I haven't touched at all while working on the tail end, will just drop notes. Say it's an item with 16 straight quarter notes, maybe the 13th just disappears. The item was not touched.

I edit by drawing, never with a midi keyboard.

The notes definitely exist for a while before deleting themselves, like I mentioned they're from the beginning of the track which was then finished.

Thanks a lot for your help.
underswamp is offline   Reply With Quote
Old 11-04-2017, 04:32 PM   #11
underswamp
Human being with feelings
 
Join Date: Sep 2014
Posts: 10
Default

Quote:
Originally Posted by grinder View Post
Are you saving your work?
Before you start thinking Reaper does this because it has singled you out, this as has been said by EvilDragon is a unheard of happening. Is there anyone out there that has heard of this happening before?
This may be a new happening that said underswamp you should simmer down and let the techs into your world for a while.

Grinder
I save regularly, yes. It's not notes from the newest work being deleted, and they are not deleted in groups. It is individual notes deleting themselves in long finished MIDI items.
underswamp is offline   Reply With Quote
Old 11-04-2017, 04:48 PM   #12
juliansader
Human being with feelings
 
Join Date: Jul 2009
Posts: 1,258
Default

Off the top of my head, perhaps the MIDI Event Filter is hiding some notes?

Run the action "Filter: Show/hide filter window", and check whether options such as "Show only events that pass filter" or "Solo" have been checked.

In the bottom right corner of the MIDI editor, there is a dropdown list of channels, and if a channel is selected, a small checkbox named "Filter" will appear. This filter checkbox does not only filter channels, but also activates the full Event Filter.
juliansader is online now   Reply With Quote
Old 11-06-2017, 07:17 PM   #13
underswamp
Human being with feelings
 
Join Date: Sep 2014
Posts: 10
Default

Quote:
Originally Posted by juliansader View Post
Off the top of my head, perhaps the MIDI Event Filter is hiding some notes?

Run the action "Filter: Show/hide filter window", and check whether options such as "Show only events that pass filter" or "Solo" have been checked.

In the bottom right corner of the MIDI editor, there is a dropdown list of channels, and if a channel is selected, a small checkbox named "Filter" will appear. This filter checkbox does not only filter channels, but also activates the full Event Filter.
Thanks. I've actually already went back and corrected all the self-deleted notes, so unfortunately I guess I can't do this at this point. I'm not sure how to run those actions besides binding it to a keystroke and doing it that way. Is there a menu path I can follow? Thanks.

If I haven't already mentioned this, I upgraded to the latest version and am hoping for the best.
underswamp is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:30 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.