Old 10-29-2017, 11:43 AM   #1
flutterecho
Human being with feelings
 
Join Date: Oct 2017
Posts: 2
Default Portable install not working, 5.61 on OS X

I have followed the steps to make a portable install (copy over Reaper64 from the .dmg, move over the "/Library/Application Support/REAPER" folder). But every time I start the REAPER64.app it creates all the folders in Library/Application Support again, and uses the /Application Support folders instead of the ones in the portable directory.

All the info I've found says that if Reaper finds the reaper.ini file in the same folder as the REAPER64.app, then it will assume that this is the primary folder and only use these folders and files as a self-contained install. Is there some way to manually force Reaper to only look inside the portable folder? Any ideas?
flutterecho is offline   Reply With Quote
Old 10-29-2017, 11:52 AM   #2
serr
Human being with feelings
 
Join Date: Sep 2010
Posts: 6,438
Default

Create a new 'blank' .ini file (a standard plain text file and rename the extension to .ini). Seeing that file in the main directory IS the telltale Reaper looks for. However if the old directory paths are still written in that ini file, Reaper will follow them.
__________________
Mac Pro 8x3.33GHz i7, 16GB, 256GB SSD(OS, apps), 3x2TB 7200 HD(data); MacBook Pro 2.8GHz, 6GB, 128GB SSD HD(OS, apps), 750GB 7200 HD(data); 2xTrue Precision 8; Apogee AD-16; 2xMOTU 828mk3, Evolution UC-33e; Faderport; WiRanger, iPad & the analog mixer has retired
serr is online now   Reply With Quote
Old 10-29-2017, 05:15 PM   #3
flutterecho
Human being with feelings
 
Join Date: Oct 2017
Posts: 2
Default

Still not working. I put the empty plain text "reaper.ini" in the folder, and when I clicked on REAPER64 for the first time it scanned the plugins and populated the /Application Support/Reaper folder instead of the portable folder.

There must be some other setting somewhere that makes the REAPER64.app point to the ../Application Support/Reaper folder.
flutterecho is offline   Reply With Quote
Old 10-30-2017, 01:38 AM   #4
solger
Human being with feelings
 
solger's Avatar
 
Join Date: Mar 2013
Posts: 1,849
Default

Quote:
Originally Posted by flutterecho View Post
Still not working. I put the empty plain text "reaper.ini" in the folder, and when I clicked on REAPER64 for the first time it scanned the plugins and populated the /Application Support/Reaper folder instead of the portable folder.
Most likely file extensions are set to be hidden. So make sure via File > Get Info that the full filename is just 'reaper.ini' (reaper = name / .ini = extension) and not 'reaper.ini.txt' ('reaper.ini' = name / .txt = extension)
Shown at around 5:19: www.youtube.com/watch?v=PlsLEc5cvEM
solger is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:56 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.