Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 05-13-2018, 09:53 AM   #1
Nonlinear
Human being with feelings
 
Join Date: Apr 2018
Posts: 90
Default Envelope points set to "Move with Media Items" DON'T move with tempo changes (FIXED)

Envelope points in an automation lane are not moving with the media when tempo is changed - even with "Move envelope points with Media items" selected.

Envelope points MOVE with the item if dragged along the timeline but do not STRETCH with the item if item or project tempo is changed.

Last edited by Nonlinear; 05-14-2018 at 04:00 PM.
Nonlinear is offline   Reply With Quote
Old 05-14-2018, 04:01 PM   #2
Nonlinear
Human being with feelings
 
Join Date: Apr 2018
Posts: 90
Default

Anyone else notice this?

It appears automation envelope points are always in "Time" mode even if associated audio track is in "Beat" mode.

What is the fix or workaround?
Nonlinear is offline   Reply With Quote
Old 05-14-2018, 05:07 PM   #3
FnA
Human being with feelings
 
FnA's Avatar
 
Join Date: Jun 2012
Posts: 2,085
Default

I noticed a few versions back that MIDI take envelopes don't respect beats timebase. Never got around to reporting it or researching if someone else did already. But track envelope seems to work as I expect. You sure you got the TRACK timebase set to beats or project default (if that is beats), or just the ITEM timebase?

FnA is offline   Reply With Quote
Old 05-15-2018, 11:22 AM   #4
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 11,453
Default

Thanks, fixing that!
Justin is offline   Reply With Quote
Old 05-19-2018, 08:40 PM   #5
FnA
Human being with feelings
 
FnA's Avatar
 
Join Date: Jun 2012
Posts: 2,085
Default

Thanks for the attention to this matter. As of 5.90rc5, it appears you can adjust the tempo envelope and MIDI take envelopes will keep beat positions.

However, I first came across this situation when attempting to copy MIDI items to a position that had a different tempo. It still seems to be a problem in this case. In other words, MIDI take envelopes don't adapt to tempo changes the same way as beat based track envelopes do during move/copy of items.

Also, copy/paste of one item/take's points to another (across tempo change) seems to be suffering from the same "time-based" problem.
FnA is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:46 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.