Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 08-01-2018, 11:04 AM   #1
meradium
Human being with feelings
 
Join Date: May 2018
Posts: 38
Default Visual feedback of recorded MIDI is out of sync (FIXED)

I think I found a bug related to the handling of real-time visual feedback of recorded MIDI.

Please take note of the time changes in the master track (all square, no linear ramps...)

It seems that Reaper is unable to keep track of the time change while recording MIDI and providing visual feedback in its regular MIDI recording mode. As soon as the playhead passes the time changes the visual feedback is out of sync with the actual notes being played (as seen by looking at the MIDI activity indicator). Initially they are both on the beat. After passing the time ramp the visual feadback is lagging behind the actual recording. Once recording is stopped the visual feedback jumps into place and is on the beat again.



Interestingly though, this only seems to appear if running in "regular" mode. If I change the MIDI recording mode to either "overdub" or "replace" the visual feedback stays in sync.



Win 10 64bit latest update
Reaper 5.93 x64 rev 99fcb9
__________________
FR: One MIDI Editor to rule them all... https://forum.cockos.com/showthread....57#post2017157
meradium is offline   Reply With Quote
Old 08-04-2018, 01:56 AM   #2
meradium
Human being with feelings
 
Join Date: May 2018
Posts: 38
Default

Am I the only one experiencing this?
__________________
FR: One MIDI Editor to rule them all... https://forum.cockos.com/showthread....57#post2017157
meradium is offline   Reply With Quote
Old 08-05-2018, 06:03 AM   #3
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 11,689
Default

Duplicated, thanks!
Justin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 04:42 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.