Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 02-25-2019, 12:09 AM   #1
Mordi
Human being with feelings
 
Mordi's Avatar
 
Join Date: May 2014
Location: Norway
Posts: 517
Default [5.97] Can't shorten notes when note length is set to 1/8 (FIXED)

Windows 10 x64
Reaper 5.97 x64



In this gif I am holding Shift while moving the end of the notes. As you can see, I can't make the note shorter than 1/8th when note length is set to 1/8. If I switch to 1/16 I can make notes shorter.
Mordi is offline   Reply With Quote
Old 02-25-2019, 06:39 AM   #2
Dark River
Human being with feelings
 
Join Date: Jul 2018
Location: NC
Posts: 17
Default

Confirmed here:

In midi editor:

turn off snapping (or use shift to bypass)
with any grid setting of 16th or greater, shortening of notes is limited to 32nd

EDIT: Well, NEVERMIND...I see that this behavior is new (and deliberate) in the latest update:

>MIDI editor
>allow resizing right edges of notes down to note insert size if lower than grid size

...and I like this new behavior ...but shift (and maybe disable snap) should allow shorter lengths.

v5.971 Win10 i7
__________________
Windows 7, i7, 16GB ram.
Windows 10, i7, 16GB ram.

Last edited by Dark River; 02-26-2019 at 09:40 PM.
Dark River is offline   Reply With Quote
Old 03-12-2019, 08:44 AM   #3
Mordi
Human being with feelings
 
Mordi's Avatar
 
Join Date: May 2014
Location: Norway
Posts: 517
Default

Quote:
Originally Posted by Dark River View Post
EDIT: Well, NEVERMIND...I see that this behavior is new (and deliberate) in the latest update:
Huh, okay. I didn't catch that. I guess I should keep an eye out for updates when I do bug reports.

However, I do find it weird that setting the grid size to 1/8 won't let me go shorter than 1/8, but setting it to 1/16 lets me go as short as I want.

Edit: I'm going slightly mad with this new behaviour. In my experience, I can sometimes shorten notes down and sometimes not. It's very inconsistent. This new behaviour just means I have to sometimes move my mouse to the "note length" dropdown and roll my mousewheel up a little every once in a while.

Is there any way to make shift disable this new behaviour? If not, I'll make a FR.

Last edited by Mordi; 03-12-2019 at 01:48 PM.
Mordi is offline   Reply With Quote
Old 03-25-2019, 06:39 AM   #4
ovnis
Human being with feelings
 
ovnis's Avatar
 
Join Date: Oct 2011
Posts: 1,309
Default

Quote:
Originally Posted by Dark River View Post
...and I like this new behavior
Why ?!!
ovnis is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 06:43 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.