Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 04-15-2019, 04:39 AM   #1
Neutronic
Human being with feelings
 
Neutronic's Avatar
 
Join Date: Sep 2013
Posts: 287
Default Sweeping mute/solo buttons ignores hidden grouped tracks

To expand on the thread title, if we:
a) have 4 tracks,
b) assign them to two groups (1+2, 3+4),
c) hide tracks 2 and 4 in either TCP/MCP,
d) and then sweep mono/stereo buttons of tracks 1 and 3
- the hidden tracks will not get muted/soloed as expected.

Below is a licecap illustrating the behavior happening in a multitimbral instruments workflow (e.g. Kontakt), where MIDI tracks are shown in the TCP only, while audio outs just in the mixer:


Last edited by Neutronic; 04-15-2019 at 09:51 PM.
Neutronic is offline   Reply With Quote
Old 04-15-2019, 02:10 PM   #2
akademie
Human being with feelings
 
Join Date: Mar 2007
Posts: 475
Default

Quote:
Originally Posted by Neutronic View Post
...
d) and then sweep mono/stereo buttons of tracks 1 and 2
- the hidden tracks will not get muted/soloed as expected.
...
Just correction, the M and S buttons are not mono/stereo, but mute/solo, as correctly stated later in the second part of d) point :-)

It would be good to correct the thread title also.
akademie is offline   Reply With Quote
Old 04-15-2019, 02:38 PM   #3
Neutronic
Human being with feelings
 
Neutronic's Avatar
 
Join Date: Sep 2013
Posts: 287
Default

Quote:
Originally Posted by akademie View Post
Just correction, the M and S buttons are not mono/stereo, but mute/solo, as correctly stated later in the second part of d) point :-)

It would be good to correct the thread title also.
Ah of course! Thanks for pointing this out. The title is corrected.
Neutronic is offline   Reply With Quote
Old 04-15-2019, 03:24 PM   #4
akademie
Human being with feelings
 
Join Date: Mar 2007
Posts: 475
Default

It seems like a bug, because grouped mute/solo buttons do mute/solo all group track (visible or not) correctly when clicked, but failed to do so when sweeped, as you wrote in OP.
akademie is offline   Reply With Quote
Old 04-15-2019, 07:29 PM   #5
akademie
Human being with feelings
 
Join Date: Mar 2007
Posts: 475
Default

Maybe another bug is that if you disable grouping, then clicking mute button on tracks is independent on each other (= ok), but when sweeping across all tracks, they behave like they are grouped!!! So as you sweep across the first track in a group it immediately triggers mutes on all "grouped" tracks (! while grouping is disabled at that time !).
:-(

This one is more a general buggy behaviour, not related to hidden tracks status.
akademie is offline   Reply With Quote
Old 04-15-2019, 09:06 PM   #6
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,066
Default

Quote:
Originally Posted by Neutronic View Post
To expand on the thread title, if we:
a) have 4 tracks,
b) assign them to two groups (1+2, 3+4),
c) hide tracks 2 and 4 in either TCP/MCP,
d) and then sweep mono/stereo buttons of tracks 1 and 2
- the hidden tracks will not get muted/soloed as expected.
Thanks, fixing!
Justin is online now   Reply With Quote
Old 04-16-2019, 12:53 AM   #7
akademie
Human being with feelings
 
Join Date: Mar 2007
Posts: 475
Default

Quote:
Originally Posted by Justin View Post
Thanks, fixing!
Great Justin, thanks.

Will also the problem that I described in post #5 be covered in that fix, please?

akademie
akademie is offline   Reply With Quote
Old 04-16-2019, 06:14 AM   #8
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,066
Default

Quote:
Originally Posted by akademie View Post
Great Justin, thanks.

Will also the problem that I described in post #5 be covered in that fix, please?

akademie
Hmm that was (previosuly) fixed in 5.974 I think?
Justin is online now   Reply With Quote
Old 04-16-2019, 06:18 AM   #9
akademie
Human being with feelings
 
Join Date: Mar 2007
Posts: 475
Default

Quote:
Originally Posted by Justin View Post
Hmm that was (previosuly) fixed in 5.974 I think?
Ohh, sorry then, I am on Reaper v5.973dev+0314 (32bit on Win7). So I take it back. Thank you.
akademie is offline   Reply With Quote
Old 04-16-2019, 07:18 AM   #10
Neutronic
Human being with feelings
 
Neutronic's Avatar
 
Join Date: Sep 2013
Posts: 287
Default

Quote:
Originally Posted by Justin View Post
Thanks, fixing!
Thanks! Also, I have just found out that the same behavior happens when sweeping Rec Arm buttons. It would be nice to fix it as well.
Neutronic is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 06:44 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.