Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 05-05-2019, 01:07 PM   #1
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 22,838
Default MIDI event properties: incorrect conversion from channel AT to poly AT (FIXED)

When you have a channel AT event, and you want to convert it to poly AT event, the value of channel AT event doesn't get converted correctly. In fact, the channel AT value becomes the note of poly AT event. I would have expected for the value to be retained, then you'd select the note you want.

This makes it really hard to convert what you draw as channel AT into poly AT for a specific note.

Interestingly, this seems to work fine when converting a bunch of CCs to poly AT. Just not when doing channel AT to poly AT, which is a shame.
EvilDragon is offline   Reply With Quote
Old 05-05-2019, 08:16 PM   #2
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,070
Default

Yeah this is because of what the first byte of the event is used for.. but an easy fix anyway.
Justin is offline   Reply With Quote
Old 05-05-2019, 11:03 PM   #3
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 22,838
Default

I figured it was due to the first byte of the MIDI message. But thanks for looking into a fix.
EvilDragon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:02 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.