Old 09-18-2019, 01:17 PM   #1
Edgemeal
Human being with feelings
 
Edgemeal's Avatar
 
Join Date: Apr 2016
Location: ASU`ogacihC
Posts: 1,482
Default WM_COPYDATA - Filename bug? (FIXED)

From v5.78 - March 25 2018...
Quote:
+ Windows: support third party applications inserting media with options (WM_COPYDATA
Passing files (WAV,etc) to REAPER works fine, unless the filename contains the '#' character, then the file isn't added correctly. Seems REAPER is trimming the filename after the # char, so if I try to pass a file named, "64_Hat_Clsd#2__RR4.wav", REAPER adds an empty/offline item named "2__RR4.wav".

Also, when adding items this way nothing is added to the UndDo History and REAPER also doesn't know anything has changed, so you could possibly exit REAPER and loose everything added.

Win10 / REAPER v5.983 x64

Last edited by Edgemeal; 09-18-2019 at 01:32 PM.
Edgemeal is offline   Reply With Quote
Old 09-19-2019, 05:35 AM   #2
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,560
Default

Hmm looking at the code, that is only an issue if you're starting the string with a # prefix (for use of #START: etc), right? Fixing!
Justin is online now   Reply With Quote
Old 09-19-2019, 06:17 AM   #3
Edgemeal
Human being with feelings
 
Edgemeal's Avatar
 
Join Date: Apr 2016
Location: ASU`ogacihC
Posts: 1,482
Default

Ya I'm using the prefix "#NOTAB#" so files are added to current tab, if I excluded the notab prefix it adds file to new tab OK. Thanks!

EDIT: Fixed in v5.984

Last edited by Edgemeal; 10-12-2019 at 09:13 AM.
Edgemeal is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 06:23 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.