Old 12-19-2019, 11:50 AM   #1
Georgedayren
Human being with feelings
 
Join Date: May 2017
Posts: 57
Default Fast Access Pack for LBX Stripper

Hello and welcome!

Preview
https://www.youtube.com/watch?v=p3JxdqkDWH8


Fast Access Pack - pack of ready-use strips for LBX Stripper

At this moment this pack supports about 600 plugins:
All JS and Cockos plugins
All FabFilter (vst2)
All MeldaProduction v14.02 (vst3)
All Valhalla (vst2)
All SoundToys except Little Plate (vst2)
All AirWindows (vst2)

Going to reach about 2000 (perhaps more) plugins in next year.
This thread for support and suggestions.

Download link for new users FAP 0.2
All instructions inside archive.

Link for download only strips FAP 0.2s
Check this: JS Dynamics ZenoMOD Pack for LBX Stripper

__________________
Donate
Fast Access Pack

Last edited by Georgedayren; 01-24-2020 at 10:34 AM.
Georgedayren is online now   Reply With Quote
Old 12-19-2019, 12:09 PM   #2
Ozman
Human being with feelings
 
Join Date: Feb 2015
Posts: 628
Default

Now this is KILLER!
Georgedayren, you are doing a great thing here with these strips.
Man... please keep up the good work!
And much thanks goes to lb0 for this awesome tool!

Last edited by Ozman; 12-19-2019 at 09:12 PM.
Ozman is offline   Reply With Quote
Old 12-19-2019, 03:19 PM   #3
Nostrap
Human being with feelings
 
Join Date: Dec 2017
Posts: 107
Default

Really great work!
Nostrap is offline   Reply With Quote
Old 12-19-2019, 03:41 PM   #4
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,426
Default

Holy crap!! Amazing! Thanks!

Great video - and massive amount of work in there!
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal

Last edited by lb0; 12-19-2019 at 06:19 PM.
lb0 is online now   Reply With Quote
Old 12-19-2019, 06:18 PM   #5
_Stevie_
Human being with feelings
 
_Stevie_'s Avatar
 
Join Date: Oct 2017
Posts: 3,310
Default

Holy crap indeed!!!
__________________
My Reascripts forum thread | My Reascripts on GitHub | Stephan Römer - film composer
If you wish to donate for my scripts: please consider an organization like: animal shelter, doctors without borders, UNICEF, etc...
_Stevie_ is offline   Reply With Quote
Old 12-19-2019, 06:19 PM   #6
heda
Human being with feelings
 
heda's Avatar
 
Join Date: Jun 2012
Location: Spain
Posts: 5,665
Default

indeed very amazing! thank you
downloading and perfect time to try LBX stripper for me
heda is offline   Reply With Quote
Old 12-19-2019, 06:21 PM   #7
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,426
Default

I now feel I need to make a batch exporter/importer which also associates the strips with the plugins... Just so it's easier for those already using Stripper.

Will look into...

For new users - simply follow the instructions George has provided.

For existing users - copy the controls/graphics and strip folders within the strip folder to LBXCS_resources folder. Careful though if you have existing associated strips - as you would want to merge the pluginsdefaults.lbx files together manually or do it plugin by plugin within Stripper.

But - give me a few days and I'll try to come up with making this easier.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal

Last edited by lb0; 12-20-2019 at 02:40 AM.
lb0 is online now   Reply With Quote
Old 12-19-2019, 06:22 PM   #8
_Stevie_
Human being with feelings
 
_Stevie_'s Avatar
 
Join Date: Oct 2017
Posts: 3,310
Default

Haha, weeeeeeee!!!
__________________
My Reascripts forum thread | My Reascripts on GitHub | Stephan Römer - film composer
If you wish to donate for my scripts: please consider an organization like: animal shelter, doctors without borders, UNICEF, etc...
_Stevie_ is offline   Reply With Quote
Old 12-19-2019, 07:39 PM   #9
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,426
Default

Ok - I stayed up late - will regret tomorrow at work

Updated Stripper with a quick function to associate all strips in a strip browser folder with their plugin.

Had to tweak some things as associating with the JS plugins wasn't working - but hopefully will now (and hopefully not missed anything to mess anything else up)

Simply shift+right-click on any strip in the strip browser (not in FAVs folder though). Choose the new option Associate All Strips With Plugins.

Obviously - use with caution - as it will overwrite any old associations for the same plugins. So maybe first backup the plugindefaults.lbx file in the LBXCS_resources/strips/ folder.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 12-20-2019, 02:27 AM   #10
Georgedayren
Human being with feelings
 
Join Date: May 2017
Posts: 57
Default

lb0
Thanks for operativeness! Here will be 2 archives in the future, one for new user, another one for existing with their own strips and settings. But in first case users will have stylized "dynamic_placeholder" for new plugins, in second case - original.
__________________
Donate
Fast Access Pack
Georgedayren is online now   Reply With Quote
Old 12-20-2019, 09:20 AM   #11
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,426
Default

Quote:
Originally Posted by Georgedayren View Post
lb0
Thanks for operativeness! Here will be 2 archives in the future, one for new user, another one for existing with their own strips and settings. But in first case users will have stylized "dynamic_placeholder" for new plugins, in second case - original.
Good idea. The only thing I can think of at the moment is your instructions don't express the requirement of SWS and Julian's API for Stripper to run properly (unless I missed it).

I've now added some batch import and export functions for share strips to the strip browser. These may come in useful. Right-click the folder button on top right of the strip browser dialog window. I also added the aforementioned Associate All Strips With Plugins to this menu as it seems better placed here.

hosting pictures
Attached Images
File Type: png Batch options.png (47.2 KB, 66 views)
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 12-20-2019, 09:49 AM   #12
Zeno
Human being with feelings
 
Zeno's Avatar
 
Join Date: Sep 2018
Location: Germany
Posts: 205
Default

Hey, great job!
Some things just don't quite work out for me.
Maybe one of you can give me some advice?
First I had some problems implementing the instructions for ReaEQ because the strip didn't accept my saved default preset and loaded another one instead. By wildly clicking around in EDIT mode I somehow managed to get it to load my preset for ReaEQ.
I tried to do the same for the ReaComp, because I always start with a 20ms att, 200ms rel and 4:1 ratio.
The classic attack button also triggered weird knee. I fixed that and added a button to the strip that switches between main input and aux input on detector input.
The problem is that the strip does not load after saving. When I insert ReaComp on a track the strip is not loaded in the LBX stripper. If I insert ReaComp in the LBX stripper, nothing happens. If I load ReaComp in EDIT-Mode the GUI says that the plugin is not found.
What am I doing wrong? Why are the presets that are saved as default not accepted? And why does LBX not find the ReaComp anymore?

Last edited by Zeno; 12-20-2019 at 10:25 AM.
Zeno is online now   Reply With Quote
Old 12-20-2019, 10:39 AM   #13
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,426
Default

Quote:
Originally Posted by Zeno View Post
Hey, great job!
Some things just don't quite work out for me.
Maybe one of you can give me some advice?
First I had some problems implementing the instructions for ReaEQ because the strip didn't accept my saved default preset and loaded another one instead. By wildly clicking around in EDIT mode I somehow managed to get it to load my preset for ReaEQ.
I tried to do the same for the ReaComp, because I always start with a 20ms att, 200ms rel and 4:1 ratio.
The classic attack button also triggered weird knee. I fixed that and added a button to the strip that switches between main input and aux input on detector input.
The problem is that the strip does not load after saving. When I insert ReaComp on a track the strip is not loaded in the LBX stripper. If I insert ReaComp in the LBX stripper, nothing happens. If I load ReaComp in EDIT-Mode the GUI says that the plugin is not found.
What am I doing wrong? Why are the presets that are saved as default not accepted? And why does LBX not find the ReaComp anymore?
When Stripper loads an instance of a plugin - it's loading it from an fx chunk stored in the strip file. Therefore - it will load with the exact settings it was saved with - which is not necessarily the default preset. So to update this you would need to edit the strip (using DM modes - Edit Strip option) - set the parameters how you need them - then resave the strip.

Regarding the ReaComp issue - can you please send me a copy of the ReaComp strip file and your plugindefaults.lbx file from LBXCS_resources - I'll PM you my email.

Alternatively - reset everything so Reacomp is found again (replace the plugindefaults.lbx file with the one from George's zip file, and also the ReaComp.strip file).

Then when it's working again - edit the strip.

Here's an example how to edit a strip and save it with different settings: Note - to pull up the switcher menu with 'edit strip' option - Shift+Right click on the switcher.

lucy and natsu wallpaper
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal

Last edited by lb0; 12-20-2019 at 11:16 AM.
lb0 is online now   Reply With Quote
Old 12-20-2019, 12:11 PM   #14
Zeno
Human being with feelings
 
Zeno's Avatar
 
Join Date: Sep 2018
Location: Germany
Posts: 205
Default

Quote:
Originally Posted by lb0 View Post
Shift+Right click on the switcher.
Thanks a lot!
The tip with the shift+right click was decisive. Now everything works
I had always manually switched to editmode (from sidebar) before.
Zeno is online now   Reply With Quote
Old 12-20-2019, 01:40 PM   #15
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,426
Default

Quote:
Originally Posted by Zeno View Post
Thanks a lot!
The tip with the shift+right click was decisive. Now everything works
I had always manually switched to editmode (from sidebar) before.
Ah great! I think this method (which works best in Dynamic Mode) makes things easier - but if you're used to the old way - it takes more getting used to!
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 12-20-2019, 07:17 PM   #16
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,426
Default

Hey George,

Just a quick heads up for you to check something.

I've been testing a few of the strips - and I found a few bugs with the MRhythmizer strip.

For me at least - the parameters are not assigned correctly. I simply went in and reassigned the parameters and it worked fine after that.

Is it like this for you - or does your one work ok?

So far - everything else is working just fine

Although I worked out that some of my JS plugins are in different locations to yours which means they do not get assigned properly at first. I'm thinking of a way to fix this so it's not a problem in the future. Probably just need to check existence of the file using the filename stored in the chunk data - and if it is missing - search for the correct location and update it in the chunk data. Annoyingly this is not quite as simple as it should be as some JS plugins contain a '/' in the filename - which of course means it's harder to identify the proper plugin name to search for - but I'm pretty sure it can be done...


EDIT:

Also had a few issues with MAutopan - where the custom mapped controls didn't work. I fixed this also by remapping things and editing the plugin mappings to include the custom mapped parameters.

I should add - I'm using the latest beta 14.02 of Melda plugins.

EDIT 2:

Final edit for tonight - Found assignment issues also with MDistortionMB. I updated Stripper just now with an extra menu option on the right-click menu in edit mode (when no controls are selected - clicking in blank space). This 'Check Control Assignments' option goes through all the controls and checks the stored parameter names against the plugins ones - and reassigns them if they don't match.

The thing I'm finding - at least with the 14.02 versions is that the parameter names are different. So things like:

Shape - Shape becomes Shape -> Shape

I've found lots of examples like this. All it means is that it's nearly impossible to automatically reassign the controls should they have moved.

What version of Melda plugins did you create these with - I shall install and check with the same edition. But V14.01 came out pretty recently - so I guess you created some of these strips with an older version?

Hopefully things will settle down like this and things will not likely change so much. But parameter number changes are really problematic - as any changes to a parameters number will likely mess up any automation (envelopes etc) existing in a project - as well as any strips in Stripper.

I requested a few days back to Vojtech if he could make the LP and HP slopes automatable in MAutoDynamicEQ - and he has in the beta - but he added the parameters early in the parameter list - and hence shifting down all subsequent parameters. I have mentioned that it would probably be best to add them at the end - so we'll see what he says. - EDIT - he got back to me and says it's a bug - so is fixing the beta.

So my main concern at the moment is that some of your Melda strips (I found 5 or 6) - do not work properly out of the box with the latest Melda updates. Hopefully after the next main release - we can fix them for the latest versions and then they will be stable for a while.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal

Last edited by lb0; 12-21-2019 at 03:21 AM.
lb0 is online now   Reply With Quote
Old 12-20-2019, 11:28 PM   #17
gluvju
Human being with feelings
 
Join Date: Nov 2019
Location: Ho Chi Minh City, Vietnam
Posts: 3
Default I have problem touching the knob

I've follow all of the instructions but I cannot control any plug-in through this strip, everytime I touch any knob from this strip this message always appear then the LBX window crash!

...dmin\AppData\Roaming\REAPER\Scripts\LBX\LBX Stripper.lua:57782: attempt to call a nil value (field 'JS_Mouse_SetCursor')

Did i do somthing wrong? Sorry for my bad English

Oh I've updated the Reaper Pack to the latest ver and it works, thanks for the strip )))

Last edited by gluvju; 12-21-2019 at 12:08 AM.
gluvju is offline   Reply With Quote
Old 12-21-2019, 02:49 AM   #18
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,426
Default

Quote:
Originally Posted by gluvju View Post
I've follow all of the instructions but I cannot control any plug-in through this strip, everytime I touch any knob from this strip this message always appear then the LBX window crash!

...dmin\AppData\Roaming\REAPER\Scripts\LBX\LBX Stripper.lua:57782: attempt to call a nil value (field 'JS_Mouse_SetCursor')

Did i do somthing wrong? Sorry for my bad English

Oh I've updated the Reaper Pack to the latest ver and it works, thanks for the strip )))
Hi, You need to install Julian Sader's ReascriptAPI (and SWS in case you haven't got that either).

Julian's API:

https://forum.cockos.com/showthread.php?t=212174

SWS:

http://www.standingwaterstudios.com/
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 12-21-2019, 03:21 AM   #19
Zeno
Human being with feelings
 
Zeno's Avatar
 
Join Date: Sep 2018
Location: Germany
Posts: 205
Default

@George:
Info: the valhalla strips also work for vst3

@Ib0:
I have a question about the FabFilter-strips. I have installed the bundle as vst3. Is it possible to assign a vst2-strip to a vst3-plugin (different ID)?
Zeno is online now   Reply With Quote
Old 12-21-2019, 04:01 AM   #20
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,426
Default

Quote:
Originally Posted by Zeno View Post
@George:
Info: the valhalla strips also work for vst3

@Ib0:
I have a question about the FabFilter-strips. I have installed the bundle as vst3. Is it possible to assign a vst2-strip to a vst3-plugin (different ID)?
What you'd need to do is use the EDIT strip option - delete the plugin (on the LBX_EDIT track). Insert the VST version you want of the plugin. Finally check that all parameters are correctly mapped and if not - simply reassign any. The new Check Control Assignments menu option can be useful here (assuming the parameters are named in exactly the same way between vst2 and vst3 plugins).

__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 12-21-2019, 05:03 AM   #21
Georgedayren
Human being with feelings
 
Join Date: May 2017
Posts: 57
Default

Quote:
Originally Posted by lb0 View Post
Good idea. The only thing I can think of at the moment is your instructions don't express the requirement of SWS and Julian's API for Stripper to run properly (unless I missed it).
ok, fixing.

About Melda. It's all complicated, about week-two ago updated to 14.00 (From v13), a lot of plugins have
Quote:
Shape - Shape becomes Shape -> Shape
issue. Fixed, but, as you said, 14.02 still have this problem. I think, version changing will repeat this again and again. First solution - turn off v10 automation compatibility mode and manually reassign controls for every plugin.

Second thing with Melda - some parameters changing assignment with changing plugins preset. One way - talk with developers. A lot of work for them..

Added later: Fixed instructions, added updater(you can find it in settings (Shift+/))
__________________
Donate
Fast Access Pack

Last edited by Georgedayren; 12-21-2019 at 05:26 AM.
Georgedayren is online now   Reply With Quote
Old 12-21-2019, 06:29 AM   #22
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,426
Default

Quote:
Originally Posted by Georgedayren View Post
ok, fixing.

About Melda. It's all complicated, about week-two ago updated to 14.00 (From v13), a lot of plugins have

issue. Fixed, but, as you said, 14.02 still have this problem. I think, version changing will repeat this again and again. First solution - turn off v10 automation compatibility mode and manually reassign controls for every plugin.

Second thing with Melda - some parameters changing assignment with changing plugins preset. One way - talk with developers. A lot of work for them..

Added later: Fixed instructions, added updater(you can find it in settings (Shift+/))
Yeah - I think Melda messed things up from 13 -> 14. Looks like some/many of the parameter numbers changed - or if not that - the internal Param assignments (that you use the MAP button for) - get lost or something.

I think if I can pinpoint the issue - I'll speak with Vojtech and hopefully avoid this in the future.

Can you remember what version you used to create say the MAutopan strip? - that's one where the internal parameters seem not to be mapped correctly. (I'm wondering if it's just the chunk data is not compatible between versions - but that would surely also affect any Reaper project saved with this data.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 12-21-2019, 06:32 AM   #23
Zeno
Human being with feelings
 
Zeno's Avatar
 
Join Date: Sep 2018
Location: Germany
Posts: 205
Default

Quote:
Originally Posted by lb0 View Post
What you'd need to do is use the EDIT strip option - delete the plugin (on the LBX_EDIT track). Insert the VST version you want of the plugin. Finally check that all parameters are correctly mapped and if not - simply reassign any. The new Check Control Assignments menu option can be useful here (assuming the parameters are named in exactly the same way between vst2 and vst3 plugins).
LBX Stripper is a really great and comprehensive script, but I just can't get it to work. Something I seem to be doing wrong, but I just don't know what.

Zeno is online now   Reply With Quote
Old 12-21-2019, 06:37 AM   #24
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,426
Default

Quote:
Originally Posted by Zeno View Post
LBX Stripper is a really great and comprehensive script, but I just can't get it to work. Something I seem to be doing wrong, but I just don't know what.

Ok - in that video - do exactly what you have done - but first you need to left click and hold on the plugin name (in the top half of the sidebar). Then drag it over one of the controls on the strip - this should reassign all of the controls at once to the new plugin - then run the right-click Check Control option...

Some params may still require manual correction/reassignment - where you just drag each parameter from the list on the left over the appropriate control on the strip.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 12-21-2019, 06:58 AM   #25
Zeno
Human being with feelings
 
Zeno's Avatar
 
Join Date: Sep 2018
Location: Germany
Posts: 205
Default

Quote:
Originally Posted by lb0 View Post
Ok - in that video - do exactly what you have done - but first you need to left click and hold on the plugin name (in the top half of the sidebar). Then drag it over one of the controls on the strip - this should reassign all of the controls at once to the new plugin - then run the right-click Check Control option...

Some params may still require manual correction/reassignment - where you just drag each parameter from the list on the left over the appropriate control on the strip.
Ok, i did. the reassignment by leftclick+drag works (by the way: if i rightclick on the plugin name in the sidebar, the script crashes)



the result of Check Control option is the same as in the gif...

The problem is, even with this attempt: the strip is still broken after saving.


But I am not sure if I am doing something totally wrong, or if it is the plugin or the script.
I tried to build a strip for pro-c2 from scratch yesterday, as I saw in your yt tutorial. The result was also broken.

Last edited by Zeno; 12-21-2019 at 07:07 AM.
Zeno is online now   Reply With Quote
Old 12-21-2019, 07:17 AM   #26
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,426
Default

Quote:
Originally Posted by Zeno View Post
Ok, i did. the reassignment by leftclick+drag works (by the way: if i rightclick on the plugin name in the sidebar, the script crashes)


the result of Check Control option is the same as in the gif...

The problem is, even with this attempt: the strip is still broken after saving.


But I am not sure if I am doing something totally wrong, or if it is the plugin or the script.
I tried to build a strip for pro-c2 from scratch yesterday, as I saw in your yt tutorial. The result was also broken.
Thanks for the heads up on the bug - fixed that!

When the plugin is changed - I suspect the associations need to be remade.

Here are a few ways to try this - does any of these work for you?

__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 12-21-2019, 07:25 AM   #27
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,426
Default

I just updated Stripper again - had to fix a few other things to do with association manager due to some recent changes.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 12-21-2019, 07:40 AM   #28
Georgedayren
Human being with feelings
 
Join Date: May 2017
Posts: 57
Default

Quote:
Originally Posted by lb0 View Post
Can you remember what version you used to create say the MAutopan strip? - that's one where the internal parameters seem not to be mapped correctly. (I'm wondering if it's just the chunk data is not compatible between versions - but that would surely also affect any Reaper project saved with this data.
That was 13.04 or 13.06
__________________
Donate
Fast Access Pack
Georgedayren is online now   Reply With Quote
Old 12-21-2019, 08:31 AM   #29
Zeno
Human being with feelings
 
Zeno's Avatar
 
Join Date: Sep 2018
Location: Germany
Posts: 205
Default

Quote:
Originally Posted by lb0 View Post
Thanks for the heads up on the bug - fixed that!

When the plugin is changed - I suspect the associations need to be remade.

Here are a few ways to try this - does any of these work for you?
Hmm... I don't know. I can't even find that option. I don't have that top shelf like you have either.
(I opened the settings menu so the version number is visible).




I did the update about 5 minutes ago via github. updates within the script seem to fail
(\AppData\Roaming\REAPER\Scripts\LBX\LBXCS_resourc es\updater\ssl.dll cannot be found... but the path is correct and ssl.dll exists)
Zeno is online now   Reply With Quote
Old 12-21-2019, 09:11 AM   #30
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,426
Default

Quote:
Originally Posted by Zeno View Post
Hmm... I don't know. I can't even find that option. I don't have that top shelf like you have either.
(I opened the settings menu so the version number is visible).




I did the update about 5 minutes ago via github. updates within the script seem to fail
(\AppData\Roaming\REAPER\Scripts\LBX\LBXCS_resourc es\updater\ssl.dll cannot be found... but the path is correct and ssl.dll exists)
Hmmm - odd about the dll not found. There are a few batch files I think to make that work - maybe they need tweaking?

The Strip Browser is opened by pressing 0 (zero).
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 12-21-2019, 10:18 AM   #31
Cooker
Human being with feelings
 
Join Date: Jun 2008
Posts: 39
Default

?

error; LBX Stripper.lua:91102: attempt to compare nil with string
Cooker is online now   Reply With Quote
Old 12-21-2019, 10:28 AM   #32
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,426
Default

Quote:
Originally Posted by Cooker View Post
?

error; LBX Stripper.lua:91102: attempt to compare nil with string
What stripper version are you on?
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 12-21-2019, 10:41 AM   #33
Zeno
Human being with feelings
 
Zeno's Avatar
 
Join Date: Sep 2018
Location: Germany
Posts: 205
Default

Quote:
Originally Posted by lb0 View Post
Hmmm - odd about the dll not found. There are a few batch files I think to make that work - maybe they need tweaking?

The Strip Browser is opened by pressing 0 (zero).
Hmm.. Maybe... but the way over github is okay.

Ok, thank you. Hmm.. you have to know about the 0 first. Would it be a good idea to integrate something like an easily accessible command list into the user interface?
Zeno is online now   Reply With Quote
Old 12-21-2019, 10:57 AM   #34
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,426
Default

Quote:
Originally Posted by Zeno View Post
Hmm.. Maybe... but the way over github is okay.

Ok, thank you. Hmm.. you have to know about the 0 first. Would it be a good idea to integrate something like an easily accessible command list into the user interface?
Maybe when I get lots of time... Until then...

https://forum.cockos.com/showpost.ph...postcount=6158
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 12-21-2019, 01:28 PM   #35
Cooker
Human being with feelings
 
Join Date: Jun 2008
Posts: 39
Default

Quote:
Originally Posted by lb0 View Post
What stripper version are you on?
Probably screwed-up something when trying to intall, will try again tomorrow (thanks for the reply)
Cooker is online now   Reply With Quote
Old 12-21-2019, 01:35 PM   #36
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,426
Default

Quote:
Originally Posted by Cooker View Post
Probably screwed-up something when trying to intall, will try again tomorrow (thanks for the reply)
OK - let me know if you have any problems. The line number for the error message could not have corresponded with the latest version or the one provided by George, so I would need to know the version number to fix the error. (The version number is indicated by the SCRIPT version number near the top of the code). If Stripper runs at all - you can press Shift+/ (?) to open the settings and it says on top left of dialog.

EDIT:

I think you may have been running a version of reaper that is too old (and that doesn't contain the necessary version check API) - or maybe it's your OS causing my checking code not to work.

I've updated Stripper - please try the update - and see if it gives you a more helpful message rather than an error...

EDIT: Nope that didn't work - seems the reaper version string has a different format which is causing the error. Will fix soon once I have a bit more detail (somebody else having this same issue is helping me out with it).
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal

Last edited by lb0; 12-22-2019 at 07:01 AM.
lb0 is online now   Reply With Quote
Old 12-21-2019, 02:52 PM   #37
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,718
Default

Wow this is huge!

also way over my league but i am watching happily! Thumbs Up!
timbralzoom is offline   Reply With Quote
Old 12-22-2019, 04:50 AM   #38
Zeno
Human being with feelings
 
Zeno's Avatar
 
Join Date: Sep 2018
Location: Germany
Posts: 205
Default

Oh, man, it was definitely me. I hadn't seen the hidden lbx_edit track and had been editing the track where I had inserted the plugin all along. Now everything runs smoothly.
Thanks again for your help Ib0.
And thanks for your great work, George!
Zeno is online now   Reply With Quote
Old 12-22-2019, 07:54 AM   #39
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,426
Default

Quote:
Originally Posted by Cooker View Post
Probably screwed-up something when trying to intall, will try again tomorrow (thanks for the reply)
This one should be fixed now - it seems some systems do not display the architecture type at the end of the reaper version string - eg. /x64. So I've tweaked it to not cause an error if this is missing.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 12-22-2019, 09:38 AM   #40
Vagelis
Human being with feelings
 
Join Date: Oct 2017
Location: Larisa, Greece
Posts: 502
Default

WOW!!! That's extremely amazing!! Huge thanks to you and of course to IBO for his out of this world scripts!!
Vagelis is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 04:18 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.