Old 04-29-2020, 10:25 AM   #1
Gass n Klang
Human being with feelings
 
Gass n Klang's Avatar
 
Join Date: Nov 2015
Location: Detmold - Germany
Posts: 661
Default Allow feedback bug

hey guys,
I think I found a bug. Load the project file and insert a media item to track B. There is a feedbackloop between Track B and C. A should send to D. As long as the "allow feedback routing" option in the project settings is disabled, A does not send to D even the feedback just occurs between Track B and C. If I allow feedback, then A also sends to D.
Attached Files
File Type: rpp Feedback-Bug.RPP (5.0 KB, 25 views)
__________________
https://gassnklang.de
Gass n Klang is offline   Reply With Quote
Old 04-29-2020, 10:26 AM   #2
Fabian
Human being with feelings
 
Fabian's Avatar
 
Join Date: Sep 2008
Location: Sweden
Posts: 5,821
Default

The same as here https://forum.cockos.com/showthread.php?t=234605?
__________________
// MVHMF
I never always did the right thing, but all I did wasn't wrong...
Fabian is offline   Reply With Quote
Old 04-29-2020, 10:38 AM   #3
akademie
Human being with feelings
 
Join Date: Mar 2007
Posts: 1,607
Default

The feedback routing is in the children (B and C) of a parent (A) so even parent (A) is affected. I don't think thatthe behavior is wrong in this case.

(as soon as you remove feedback from children, by unticking parent send on track C, audio gets routed normally to track D)
akademie is offline   Reply With Quote
Old 04-30-2020, 01:36 AM   #4
Gass n Klang
Human being with feelings
 
Gass n Klang's Avatar
 
Join Date: Nov 2015
Location: Detmold - Germany
Posts: 661
Default

yes but I don't understand the context of sending A to D and the feeback between B and C...
__________________
https://gassnklang.de
Gass n Klang is offline   Reply With Quote
Old 04-30-2020, 06:05 PM   #5
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,915
Default

Fixing this!
Justin is offline   Reply With Quote
Old 05-01-2020, 02:49 AM   #6
akademie
Human being with feelings
 
Join Date: Mar 2007
Posts: 1,607
Default

Quote:
Originally Posted by Justin View Post
Fixing this!
Oh, nice then.
Thanks
akademie is offline   Reply With Quote
Old 05-01-2020, 06:37 AM   #7
Gass n Klang
Human being with feelings
 
Gass n Klang's Avatar
 
Join Date: Nov 2015
Location: Detmold - Germany
Posts: 661
Default

Quote:
Originally Posted by Justin View Post
Fixing this!
NICE thanks!
__________________
https://gassnklang.de
Gass n Klang is offline   Reply With Quote
Old 06-17-2020, 12:48 PM   #8
fieldswn
Human being with feelings
 
fieldswn's Avatar
 
Join Date: Oct 2006
Location: Wilmington, DE
Posts: 149
Default Feeback broken/crunchy in 6.12

Whatever was changed here broke feedback routing for me. Now when I have a channel that is feeding back, everything sounds nasty and crunchy (sounds like buffer under-runs). When I mute that channel, it sounds clean again.

It was working perfectly on all versions up until 6.12.

The RPP project is very complicated. I will see if I can reproduce it with a simple project and report back.
__________________
williamfields.com
fieldswn is offline   Reply With Quote
Old 06-17-2020, 01:25 PM   #9
fieldswn
Human being with feelings
 
fieldswn's Avatar
 
Join Date: Oct 2006
Location: Wilmington, DE
Posts: 149
Default

See attached for an example RPP.

It's a weird routing, I know.
Attached Files
File Type: rpp feedback example.RPP (9.3 KB, 7 views)
__________________
williamfields.com
fieldswn is offline   Reply With Quote
Old 06-22-2020, 05:02 AM   #10
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,915
Default

Thanks for the project! It's playing back fine here -- can you post your reaper.ini too? Also what OS, audio device, and samplerate/blocksize are you using?
Justin is offline   Reply With Quote
Old 06-23-2020, 12:49 PM   #11
fieldswn
Human being with feelings
 
fieldswn's Avatar
 
Join Date: Oct 2006
Location: Wilmington, DE
Posts: 149
Default

OS: Windows 10
Audio device: Focusrite Scarlett 18i6
Sample rate: 44.1 kHz
Block size: 128 samples

reaper.ini is attached.

I just noticed something: The problem goes away if I turn off: Anticipative FX processing > Allow on tracks without FX.

Thanks!
Attached Files
File Type: ini reaper.ini (39.0 KB, 4 views)
__________________
williamfields.com
fieldswn is offline   Reply With Quote
Old 06-24-2020, 09:31 AM   #12
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,915
Default

Thanks, I've duplicated this and am investigating!

As a workaround, you can disable anticipative FX for tracks that are affected by feedback loops, which will fix this issue (and restore the previous behavior).
Justin is offline   Reply With Quote
Old 06-24-2020, 08:18 PM   #13
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,915
Default

Should be fixed in today's +dev build!
Justin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:38 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.