Old 07-14-2020, 09:11 AM   #1
cohler
Human being with feelings
 
Join Date: Dec 2018
Posts: 453
Default Item content drag destroys fades

Dragging an item's content (using the "Move item contents" mouse modifier actions) destroys both crossfades (at start of item and end of item) with global option auto-crossfade on. When auto-crossfade is off, it works correctly.

Dragging the content of an item should have no impact on the fades at either end independent of the auto-crossfade setting. One has nothing to do with the other. Auto-crossfade should apply only to when you are moving the item itself when dragging it, not when you are moving the content of the item.

One needs to be able to move the content of items to adjust crossfade join points (as shown in the video) and the status of auto-crossfade has nothing to do with that, because the item itself is not being moved.

See video below which first shows the correct behavior with auto-crossfade off and then the incorrect behavior with auto-crossfade on.

@Justin and @Schwa can this be fixed?

__________________
Cohler Classical
The premiere platform for Classical Music & Source-Destination Editing
https://cohlerclassical.cominfo@cohlerclassical.com

Last edited by cohler; 07-14-2020 at 12:59 PM. Reason: Further explanation
cohler is online now   Reply With Quote
Old 07-14-2020, 11:22 AM   #2
Fabian
Human being with feelings
 
Fabian's Avatar
 
Join Date: Sep 2008
Location: Sweden
Posts: 6,721
Default

It doesn't seem to behave that way here


I have the auto-crossfade option on, and I slip-edit (Alt+drag on Windows) first with both items selected, and then with only the left item selected. It seems to work as expected. Not...?
__________________
// MVHMF
I never always did the right thing, but all I did wasn't wrong...
Fabian is online now   Reply With Quote
Old 07-14-2020, 11:41 AM   #3
cohler
Human being with feelings
 
Join Date: Dec 2018
Posts: 453
Default

Quote:
Originally Posted by Fabian View Post
It doesn't seem to behave that way here


I have the auto-crossfade option on, and I slip-edit (Alt+drag on Windows) first with both items selected, and then with only the left item selected. It seems to work as expected. Not...?
That's totally different from what I reported.

First, you have default, symmetrical fades.

Second, you have multiple items selected.

The error as I reported and demonstrated occurs when you have non-default fades and you move the contents of an item as described with auto-crossfade on.

The item drag reverts the fades at both ends back to default (7). Since your example starts with default it wouldn't show anything anyhow.

Another difference is that I am using the "Move item content and right edge with ripple" command. You are not in your example.
__________________
Cohler Classical
The premiere platform for Classical Music & Source-Destination Editing
https://cohlerclassical.cominfo@cohlerclassical.com
cohler is online now   Reply With Quote
Old 07-14-2020, 12:52 PM   #4
Fabian
Human being with feelings
 
Fabian's Avatar
 
Join Date: Sep 2008
Location: Sweden
Posts: 6,721
Default

Quote:
Originally Posted by cohler View Post
That's totally different from what I reported.
<snip>
Then I misunderstood. Sorry.
__________________
// MVHMF
I never always did the right thing, but all I did wasn't wrong...
Fabian is online now   Reply With Quote
Old 07-18-2020, 06:51 PM   #5
cohler
Human being with feelings
 
Join Date: Dec 2018
Posts: 453
Default Reposting bug to see if we can get response from developers @Justin or @Schwa

Dragging an item's content (using the "Move item contents" mouse modifier actions) destroys both crossfades (at start of item and end of item) with global option auto-crossfade on. When auto-crossfade is off, it works correctly.

Dragging the content of an item should have no impact on the fades at either end independent of the auto-crossfade setting. One has nothing to do with the other. Auto-crossfade should apply only to when you are moving the item itself when dragging it, not when you are moving the content of the item.

One needs to be able to move the content of items to adjust crossfade join points (as shown in the video) and the status of auto-crossfade has nothing to do with that, because the item itself is not being moved.

See video below which first shows the correct behavior with auto-crossfade off and then the incorrect behavior with auto-crossfade on.

@Justin and @Schwa can this be fixed?

__________________
Cohler Classical
The premiere platform for Classical Music & Source-Destination Editing
https://cohlerclassical.cominfo@cohlerclassical.com
cohler is online now   Reply With Quote
Old 07-19-2020, 07:32 AM   #6
joshxtra
Human being with feelings
 
Join Date: Jul 2018
Posts: 32
Default Overlapping fades get reset by item-content-drag if autocrossfade is enabled

I never noticed this, but it should definitely get fixed! A short description of the bug could be:

Overlapping fades get reset by item-content-drag if autocrossfade is enabled.
joshxtra is offline   Reply With Quote
Old 07-19-2020, 11:48 AM   #7
cohler
Human being with feelings
 
Join Date: Dec 2018
Posts: 453
Default

Quote:
Originally Posted by joshxtra View Post
I never noticed this, but it should definitely get fixed! A short description of the bug could be:

Overlapping fades get reset by item-content-drag if autocrossfade is enabled.
Yup, and an even shorter description is the thread title that I created, "Item content drag destroys fades"
__________________
Cohler Classical
The premiere platform for Classical Music & Source-Destination Editing
https://cohlerclassical.cominfo@cohlerclassical.com
cohler is online now   Reply With Quote
Old 08-16-2020, 10:50 AM   #8
cohler
Human being with feelings
 
Join Date: Dec 2018
Posts: 453
Default

Are there any plans to fix this bug? @Justin @Schwa
__________________
Cohler Classical
The premiere platform for Classical Music & Source-Destination Editing
https://cohlerclassical.cominfo@cohlerclassical.com
cohler is online now   Reply With Quote
Old 10-28-2020, 08:43 AM   #9
cohler
Human being with feelings
 
Join Date: Dec 2018
Posts: 453
Default

Will we ever get ANY RESPONSE of any kind to this MAJOR BUG?
__________________
Cohler Classical
The premiere platform for Classical Music & Source-Destination Editing
https://cohlerclassical.cominfo@cohlerclassical.com
cohler is online now   Reply With Quote
Old 12-19-2020, 05:24 PM   #10
cohler
Human being with feelings
 
Join Date: Dec 2018
Posts: 453
Default Recent bug fix, fixes only PART of this problem

The recent bug fix

+ Media items: preserve manual fade shape when clearing auto-crossfade [t=240579]

fixes the problem of fade curve shapes reverting.

It DOES NOT, however, fix the bug that still causes the fade lengths on asymmetric fades to change so that they are no longer asymmetric, ie it sets both the fadein and fadeout lengths to be exactly equal to the time between the beginning of the fade out and the end of the fade in. See p=2318985
__________________
Cohler Classical
The premiere platform for Classical Music & Source-Destination Editing
https://cohlerclassical.cominfo@cohlerclassical.com
cohler is online now   Reply With Quote
Old 12-19-2020, 08:00 PM   #11
akademie
Human being with feelings
 
Join Date: Mar 2007
Posts: 2,522
Default

I don't have that problem in REAPER v6.10 32bit on Windows10 x64.

It's working correctly here (no fade type etc. resetting) while moving contents of anyy of the overlaping items either with the Auto cross-fade option On or Off.
akademie is offline   Reply With Quote
Old 12-20-2020, 05:15 AM   #12
cohler
Human being with feelings
 
Join Date: Dec 2018
Posts: 453
Default

Quote:
Originally Posted by akademie View Post
I don't have that problem in REAPER v6.10 32bit on Windows10 x64.

It's working correctly here (no fade type etc. resetting) while moving contents of anyy of the overlaping items either with the Auto cross-fade option On or Off.
NOT working here. As I said, the fade types don't reset, but the fade lengths DO.

REAPER v6.19 64bit on OS X 10.13.6

__________________
Cohler Classical
The premiere platform for Classical Music & Source-Destination Editing
https://cohlerclassical.cominfo@cohlerclassical.com
cohler is online now   Reply With Quote
Old 12-20-2020, 07:14 AM   #13
akademie
Human being with feelings
 
Join Date: Mar 2007
Posts: 2,522
Default

Screencapture of mine

Auto crossfade ON, Mouse modifier set to "Move item contents and right edge ignoring snap, ripple edit later items".
(Win10 x64, REAPER v6.19 x86, also 6.17rc1 x86)
akademie is offline   Reply With Quote
Old 12-20-2020, 07:16 AM   #14
cohler
Human being with feelings
 
Join Date: Dec 2018
Posts: 453
Default

Quote:
Originally Posted by akademie View Post
Screencapture of mine

Auto crossfade ON, Mouse modifier set to "Move item contents and right edge ignoring snap, ripple edit later items".

Those are NOT asymmetric fades. In other words, the beginning of your fade out = the start of the 2nd item and the and the end of your fade in = the end of the first item. If you try it with ASYMMETRIC fades, you will see the behavior I described.
__________________
Cohler Classical
The premiere platform for Classical Music & Source-Destination Editing
https://cohlerclassical.cominfo@cohlerclassical.com
cohler is online now   Reply With Quote
Old 12-20-2020, 07:21 AM   #15
akademie
Human being with feelings
 
Join Date: Mar 2007
Posts: 2,522
Default

Quote:
Originally Posted by cohler View Post
Those are NOT asymmetric fades. In other words, the beginning of your fade out = the start of the 2nd item and the and the end of your fade in = the end of the first item. If you try it with ASYMMETRIC fades, you will see the behavior I described.
OK man, upload the example project (without media), please.
akademie is offline   Reply With Quote
Old 12-20-2020, 07:23 AM   #16
cohler
Human being with feelings
 
Join Date: Dec 2018
Posts: 453
Default

Quote:
Originally Posted by akademie View Post
OK man, upload the example project (without media), please.
It doesn't matter what the project is. It happens in ALL cases when set up as I described.

1. Asymmetric fades
2. Auto-crossfade on
3. Move item contents

That's it. Try it on your system with asymmetric fades and you will see.
__________________
Cohler Classical
The premiere platform for Classical Music & Source-Destination Editing
https://cohlerclassical.cominfo@cohlerclassical.com
cohler is online now   Reply With Quote
Old 12-20-2020, 07:27 AM   #17
akademie
Human being with feelings
 
Join Date: Mar 2007
Posts: 2,522
Default

Quote:
Originally Posted by cohler View Post
It doesn't matter what the project is. It happens in ALL cases when set up as I described.

1. Asymmetric fades
2. Auto-crossfade on
3. Move item contents

That's it. Try it on your system with asymmetric fades and you will see.
That's why I asked you for example project, because I don't know what you mean by asymmetric fades and how to create them. That's it.

I would think that it is not a big problem to upload mini project to showcase problem, if others try to help. Sure it is as it seems

EDIT: maybe I found it - is it the point handle where fade in/out crosses to move to create asymmetry? if yes, then it is still working correctly, not touching fade lengths..
akademie is offline   Reply With Quote
Old 12-20-2020, 07:32 AM   #18
cohler
Human being with feelings
 
Join Date: Dec 2018
Posts: 453
Default

Quote:
Originally Posted by akademie View Post
That's why I asked you for example project, because I don't know what you mean by asymmetric fades and how to create them. That's it.

I would think that it is not a big problem to upload mini project to showcase problem, if others try to help. Sure it is as it seems
That's why I uploaded a LICEcap showing exactly what I mean. Once again an asymmetric crossfade is one where:

1. Either the fade-out and fade-in lengths are DIFFERENT, or
2. The fade-out doesn't start at the same place where the 2nd item starts, or
3. The fade-in doesn't end at the same place where the 1st item ends.

As you can see clearly in the LICEcap video.

The fades that you show have equal fade-in/fade-out lengths, the fade-out starts at same place as the beginning of the 2nd item, and the fade-in ends at the same place as the end of the 1st item.

Do you understand what I'm saying? If you still do not, I will be happy to upload a small project.
__________________
Cohler Classical
The premiere platform for Classical Music & Source-Destination Editing
https://cohlerclassical.cominfo@cohlerclassical.com
cohler is online now   Reply With Quote
Old 12-20-2020, 07:36 AM   #19
akademie
Human being with feelings
 
Join Date: Mar 2007
Posts: 2,522
Default

Quote:
Originally Posted by cohler View Post
...<snip>
Do you understand what I'm saying?
Let me tell you, that I am really sad with your attitude
Keep repeating yourself with licecaps etc.
I am not gonna argue if you do not want to accept any help.

It looks like you have some configuration broken at yoour end, or it is Mac specific bug.

EDIT: Maybe someone could meet at Zoom...
akademie is offline   Reply With Quote
Old 12-20-2020, 07:48 AM   #20
akademie
Human being with feelings
 
Join Date: Mar 2007
Posts: 2,522
Default

OK, I managed it, with Auto crossfade OFF, because when on, I cannot create asymmetric crossfades, of course.
So then it works (I mean moving contents) ok when Auto crossfade is OFF.
Confirming the behavior you talk about when Auto crossfade is ON.
akademie is offline   Reply With Quote
Old 12-20-2020, 07:57 AM   #21
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 12,205
Default

Fixing, thanks for the report.
schwa is offline   Reply With Quote
Old 12-20-2020, 08:11 AM   #22
cohler
Human being with feelings
 
Join Date: Dec 2018
Posts: 453
Default

Quote:
Originally Posted by akademie View Post
Let me tell you, that I am really sad with your attitude
Keep repeating yourself with licecaps etc.
I am not gonna argue if you do not want to accept any help.

It looks like you have some configuration broken at yoour end, or it is Mac specific bug.
and

Quote:
Originally Posted by akademie View Post
OK, I managed it, with Auto crossfade OFF, because when on, I cannot create asymmetric crossfades, of course.
So then it works (I mean moving contents) ok when Auto crossfade is OFF.
Confirming the behavior you talk about when Auto crossfade is ON.
Yes, of course auto-crossfade must be off to create asymmetric fades. I never said it didn't.

My report was specifically and explicitly about when you already have asymmetric fades, as I clearly stated and showed in LICEcap. I said (emphasis added):

Quote:
"It DOES NOT, however, fix the bug that still causes the fade lengths on asymmetric fades to change so that they are no longer asymmetric, ie it sets both the fadein and fadeout lengths to be exactly equal to the time between the beginning of the fade out and the end of the fade in. See p=2318985"
I don't appreciate the condescension. What I reported was precise and complete.
__________________
Cohler Classical
The premiere platform for Classical Music & Source-Destination Editing
https://cohlerclassical.cominfo@cohlerclassical.com

Last edited by cohler; 12-20-2020 at 08:14 AM. Reason: wrong quote
cohler is online now   Reply With Quote
Old 12-20-2020, 08:12 AM   #23
cohler
Human being with feelings
 
Join Date: Dec 2018
Posts: 453
Default

Quote:
Originally Posted by schwa View Post
Fixing, thanks for the report.
Thank you!
__________________
Cohler Classical
The premiere platform for Classical Music & Source-Destination Editing
https://cohlerclassical.cominfo@cohlerclassical.com
cohler is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:35 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.