Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 07-31-2020, 05:34 AM   #1
TorlanDelta
Human being with feelings
 
Join Date: Jul 2019
Posts: 30
Default A 40+ dB pop when using volume automation (FIXED)

Hello.

Whenever I use volume automation envelopes (V by default) with any sort of delay/reverb effects that have tail (or any release curve really) I get loud pops on stopping/starting playback (when the end of the volume envelope is at low, and the starting position the playhead jumps to upon stopping playback is relatively high).

Auto muting is a good tool to bypass that, sure, but it can prevent me from hearing interesting FX tails and it requires additional interaction with the DAW to unmute, which is annoying. Also, it doesn't work every time.

UPDATE: It has everything to do with "Bypass underlying envelopes outside automation items" option. It's a bug that IMO needs to be fixed.

Last edited by TorlanDelta; 09-03-2020 at 02:32 AM. Reason: TL;DR
TorlanDelta is offline   Reply With Quote
Old 07-31-2020, 05:53 AM   #2
TorlanDelta
Human being with feelings
 
Join Date: Jul 2019
Posts: 30
Default

Got 110 dB out of this one and auto muting works in like 80% of cases.

Let it play past the volume envelope and pause it, when the playhead returns to the start you get a pop, unless you've let it go past the point when the verb tail dies completely.

May be important - I have underlying envelopes turned off always.
Attached Files
File Type: rpp TESTSNAP.rpp (5.2 KB, 141 views)

Last edited by TorlanDelta; 09-01-2020 at 02:55 AM.
TorlanDelta is offline   Reply With Quote
Old 07-31-2020, 09:15 AM   #3
TorlanDelta
Human being with feelings
 
Join Date: Jul 2019
Posts: 30
Default

A notable thing is - it never happens when you automate any sort of FX's output gain. As an example I automated ReaPitch's Dry knob with the same envelope, and stopping playback never results in popping.
TorlanDelta is offline   Reply With Quote
Old 09-01-2020, 02:57 AM   #4
TorlanDelta
Human being with feelings
 
Join Date: Jul 2019
Posts: 30
Default

This is my full config export in case anyone decides to play around with it.

https://drive.google.com/file/d/16oG...ew?usp=sharing

A person on a Reaper Discord server reported not having pops unless they press a midi note during the playback.
TorlanDelta is offline   Reply With Quote
Old 09-01-2020, 12:03 PM   #5
TorlanDelta
Human being with feelings
 
Join Date: Jul 2019
Posts: 30
Default

After much testing, it turns out that this is 100% connected to turning On the option "Bypass underlying envelopes outside automation items" - after installing a portable reaper version, I had no pops, and when I turned it on - bingo.

I'm not turning this option off, and this should probably be fixed. :c
TorlanDelta is offline   Reply With Quote
Old 01-11-2022, 04:33 AM   #6
TorlanDelta
Human being with feelings
 
Join Date: Jul 2019
Posts: 30
Default

Still not fixed lmao
Attached Images
File Type: png Untitled.png (1.9 KB, 96 views)

Last edited by TorlanDelta; 01-11-2022 at 04:35 AM. Reason: added the poppiness
TorlanDelta is offline   Reply With Quote
Old 01-11-2022, 05:17 AM   #7
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 14,239
Default

Looking into this. Thanks for posting the simple project to reproduce, if every bug report came that way, there would be no bugs.
schwa is offline   Reply With Quote
Old 01-12-2022, 12:21 AM   #8
TorlanDelta
Human being with feelings
 
Join Date: Jul 2019
Posts: 30
Default

Quote:
Originally Posted by schwa View Post
Looking into this. Thanks for posting the simple project to reproduce, if every bug report came that way, there would be no bugs.
Thank you very much! Sorry for being whiny about this issue, just that every time it pops up (haha pun) it catches me by surprise and threatens to blow out either eardrums or speaker membranes.

I tested my example project last time on Reaper v6.45 64bit rev64818 from Jan 9th, 2022 (just now). 110+ dB pop.

Just for reference, I'm using Focusrite Scarlett Solo 2nd Gen, my firmware version is 1052, Driver: 4.65.5; 44.1 kHz 256 samples.

What's interesting is, Reaper still shows mega clicks when I'm running on WASAPI, but I can't hear them. Probably has something to do with a bigger buffer of WASAPI, but I'm no expert.

If there is any more info you need from me please don't hesitate to ask. I'm not that sore, I promise XD

I just really like to press V and have this "official" volume control thing, that is almost 0 latency (unlike controlling a VST/jsFX param, I think). It's also super useful for controlling reverb tails and such, and I have many projects that rely on this, and, unfortunately, pop and crackle.
TorlanDelta is offline   Reply With Quote
Old 01-12-2022, 09:43 AM   #9
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 14,239
Default

This should be fixed in the current prerelease build if you'd care to try it out.

https://forum.cockos.com/forumdisplay.php?f=37
schwa is offline   Reply With Quote
Old 01-13-2022, 12:43 AM   #10
TorlanDelta
Human being with feelings
 
Join Date: Jul 2019
Posts: 30
Default

Quote:
Originally Posted by schwa View Post
This should be fixed in the current prerelease build if you'd care to try it out.

https://forum.cockos.com/forumdisplay.php?f=37
Spent like 5-10 mins stopping/playing my test project. No pops! Thank you so much. I'm so looking forward to this release!
TorlanDelta is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 12:51 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.