Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 03-01-2021, 05:52 PM   #1
guest220119
Human being with feelings
 
guest220119's Avatar
 
Join Date: Jun 2019
Posts: 52
Default Media explorer doesn't update when done searching

I'm not sure if this is a bug or if I'm missing something. Whenever I search for something in the media explorer, a dialog comes up showing it search through my folders (as expected). But when it completes the search and the dialog goes away, the results don't show. In order to get them to show, I have to leave the current folder, come back to it, search the same thing again, and then they will show. And it doesn't have to spend time searching on the second time -- I guess because it's cached. This same issue occurs when the "update search only when enter key pressed" option is enabled, only I can just press enter a second time instead of having to leave the folder. Here is a GIF of that:



I type "kick" and hit enter, it searches, the search dialog closes, and nothing has changed. I hit enter again, and the results show. I'm using REAPER v6.23, although this has been an issue for many versions previous. Running Windows 8.1 x64.

Thanks
guest220119 is offline   Reply With Quote
Old 03-02-2021, 02:37 AM   #2
PelF
Human being with feelings
 
PelF's Avatar
 
Join Date: Mar 2013
Posts: 160
Default

+1
I also found that the word search is not displayed after the first scan database.

Last edited by PelF; 10-06-2021 at 11:39 PM.
PelF is offline   Reply With Quote
Old 03-15-2021, 04:01 AM   #3
PelF
Human being with feelings
 
PelF's Avatar
 
Join Date: Mar 2013
Posts: 160
Default

It will also happen that I catch the item and then let go. The page then returns to the beginning. It's quite annoying when I have to scroll back again.



Last edited by PelF; 10-06-2021 at 11:40 PM.
PelF is offline   Reply With Quote
Old 03-16-2021, 07:54 AM   #4
guest220119
Human being with feelings
 
guest220119's Avatar
 
Join Date: Jun 2019
Posts: 52
Default

Quote:
Originally Posted by PelF View Post
Sometimes it will also happen that I catch the item and then let go. The page then returns to the beginning. It's quite annoying when I have to scroll back again.
Perhaps it is also somehow related to search updates?
Yeah this happens to me too, very annoying
guest220119 is offline   Reply With Quote
Old 03-26-2021, 03:38 PM   #5
gavanbruderer
Human being with feelings
 
gavanbruderer's Avatar
 
Join Date: Nov 2009
Location: Ogden, Utah
Posts: 63
Default

Quote:
Originally Posted by PelF View Post
Sometimes it will also happen that I catch the item and then let go. The page then returns to the beginning. It's quite annoying when I have to scroll back again.
Perhaps it is also somehow related to search updates?



Can confirm that this issue is still present in the latest prerelease builds.
__________________
Gavan Bruderer
-------------------
www.imagingprod.com
gavanbruderer is offline   Reply With Quote
Old 05-13-2021, 12:56 PM   #6
guest220119
Human being with feelings
 
guest220119's Avatar
 
Join Date: Jun 2019
Posts: 52
Default

bump
guest220119 is offline   Reply With Quote
Old 05-26-2021, 04:39 AM   #7
PelF
Human being with feelings
 
PelF's Avatar
 
Join Date: Mar 2013
Posts: 160
Default

bump...
PelF is offline   Reply With Quote
Old 09-06-2021, 09:50 AM   #8
PelF
Human being with feelings
 
PelF's Avatar
 
Join Date: Mar 2013
Posts: 160
Default

bump bump
PelF is offline   Reply With Quote
Old 09-06-2021, 01:18 PM   #9
tonalstates
Human being with feelings
 
tonalstates's Avatar
 
Join Date: Jun 2020
Posts: 398
Default

To me it happens that the whole search results aren't shown until I press space or something like that. So +1.
tonalstates is offline   Reply With Quote
Old 11-18-2021, 12:39 AM   #10
PelF
Human being with feelings
 
PelF's Avatar
 
Join Date: Mar 2013
Posts: 160
Default

Quote:
Originally Posted by PelF View Post
It will also happen that I catch the item and then let go. The page then returns to the beginning. It's quite annoying when I have to scroll back again.

Maybe I'm wrong, but I noticed that this behavior will only take effect in the list of search items.
PelF is offline   Reply With Quote
Old 12-12-2021, 05:54 PM   #11
guest220119
Human being with feelings
 
guest220119's Avatar
 
Join Date: Jun 2019
Posts: 52
Default

PLEASE
guest220119 is offline   Reply With Quote
Old 12-23-2021, 11:29 AM   #12
guest220119
Human being with feelings
 
guest220119's Avatar
 
Join Date: Jun 2019
Posts: 52
Default

Okay so I see the "force browser to refresh after completing search" addition in v6.43 that links to this thread. I just tried it out -- it auto-refreshes correctly now, EXCEPT for the very first search after changing directory in the media explorer. On the first search, it will refresh, but with little to no results (until I hit Enter again). The following gif was recorded right after changing the directory I'm in. The "kick" search has the issue, then the next search "snare" doesn't. I've tested the inverse as well ("snare" first, "kick" second) so I know it's not the specific thing I'm searching.

https://i.imgur.com/UGmT6ir.gif

Last edited by guest220119; 12-23-2021 at 12:17 PM.
guest220119 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:04 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.