Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 01-24-2022, 12:46 AM   #1
inoto
Human being with feelings
 
Join Date: Nov 2021
Posts: 46
Default r8brain resampler adding noise (FIXED)

Using r8brain for either rendering or real time resampling produces some noise at the end of the file.

Here's a 96kHz frequency sweep rendered to 44.1kHz, first with 384pt interpolation and then with r8brain:



(Reaper 6.46 64-bit, Windows)
inoto is offline   Reply With Quote
Old 01-24-2022, 01:35 AM   #2
Tale
Human being with feelings
 
Tale's Avatar
 
Join Date: Jul 2008
Location: The Netherlands
Posts: 3,644
Default

Does your sine sweep end abruptly? If so, then this is probably the issue, and it's probably not a bug.

Note that this would mean the "noise" should be present in both waveforms, but for the 384pt Sinc it's probably less pronounced.
Tale is offline   Reply With Quote
Old 01-24-2022, 02:25 AM   #3
inoto
Human being with feelings
 
Join Date: Nov 2021
Posts: 46
Default

It ends at a very low level. It's the test sweep tone from infinitewave (direct link to the .zip).

I tested it with a few other resamplers outside of Reaper and none of them produced any noise at the end.
inoto is offline   Reply With Quote
Old 01-24-2022, 04:41 AM   #4
Tale
Human being with feelings
 
Tale's Avatar
 
Join Date: Jul 2008
Location: The Netherlands
Posts: 3,644
Default

I've just tested myself, and with Sinc 768pt there actually is a tiny bit of noise, but it's very faint, peaking at -127.6 dB. I guess this is to be expected.

But with r8bain the noise is way louder, peaking at -19 dB, so that does seem like a bug.
Tale is offline   Reply With Quote
Old 01-24-2022, 08:49 PM   #5
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 15,706
Default

Ah thanks, finally duplicated and figured this out, fixing!
Justin is offline   Reply With Quote
Old 01-25-2022, 09:59 PM   #6
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 15,706
Default

Should hopefully be fixed in the latest pre-release (see the pre-release forum for details if you like!).
Justin is offline   Reply With Quote
Old 01-26-2022, 02:14 AM   #7
inoto
Human being with feelings
 
Join Date: Nov 2021
Posts: 46
Default

Yeah it looks to be fixed, thanks!
inoto is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 12:01 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.