Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 04-05-2022, 06:03 AM   #1
ASauer
Human being with feelings
 
Join Date: Jun 2013
Posts: 22
Default "embed markers + regions" all cues are copied to the beginning of the file (FIXED)

When rendering a long file (Auto Wav/RF64) with ± 500 markers,
with "embed markers + regions",
all markers are copied to the start of the file.
The original positions of the markers are there as well.

So, if you run the action "Item: Import media item cues as project markers" you end up with twice the number of markers (in this case ± 1000 markers).

This is a 32 bit floating point wav.
With bext chunk.
Project file name included in the BWF data.

If you want I can send you the rendered file (10 GB).

Mac OSX 10.15.7
MacBook Pro (16 inch 2019)
2,4 GHz 8-Core Intel Core i9
Reaper 6.53
ASauer is offline   Reply With Quote
Old 04-05-2022, 08:26 AM   #2
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 15,848
Default

Quote:
Originally Posted by ASauer View Post
When rendering a long file (Auto Wav/RF64) with ± 500 markers,
with "embed markers + regions",
all markers are copied to the start of the file.
The original positions of the markers are there as well.
I'm not sure what this means exactly? Do you mean that if there is a marker at 0:01, two markers get embedded into the rendered file, one at 0:00 and one at 0:01?
schwa is offline   Reply With Quote
Old 04-05-2022, 09:49 AM   #3
ASauer
Human being with feelings
 
Join Date: Jun 2013
Posts: 22
Default

Yep, so 500 markers where they should be, and 500 markers at 0:00.
Each marker is duplicated.

Last edited by ASauer; 04-05-2022 at 10:06 AM.
ASauer is offline   Reply With Quote
Old 04-05-2022, 10:10 AM   #4
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 15,848
Default

Do you see this behavior when rendering a short file, or only with a very long file?
schwa is offline   Reply With Quote
Old 04-05-2022, 10:35 AM   #5
ASauer
Human being with feelings
 
Join Date: Jun 2013
Posts: 22
Default

Long (RF64) files only
ASauer is offline   Reply With Quote
Old 04-06-2022, 07:22 AM   #6
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 15,848
Default

Ahh, the problem is actually on the read side. I think these markers are embedded correctly, but REAPER is displaying them incorrectly at the start of the project when you re-import the rendered file. We'll fix the display for the next build.

Last edited by schwa; 04-06-2022 at 10:12 AM.
schwa is offline   Reply With Quote
Old 04-06-2022, 10:02 AM   #7
ASauer
Human being with feelings
 
Join Date: Jun 2013
Posts: 22
Default

Thanks a lot! I'm looking forward to the next version!
ASauer is offline   Reply With Quote
Old 04-20-2022, 04:12 PM   #8
ASauer
Human being with feelings
 
Join Date: Jun 2013
Posts: 22
Default

Is this fixed in the 6.54 release? I couldn't find it in the release notes. I will see if I can test this later next week.
ASauer is offline   Reply With Quote
Old 04-20-2022, 04:14 PM   #9
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 15,848
Default

It's not in the 6.54 release, it is still in the prerelease branch because we haven't gotten any feedback on it. If you'd care to try the latest prerelease build that would be helpful!

https://forum.cockos.com/forumdisplay.php?f=37
schwa is offline   Reply With Quote
Old 04-22-2022, 12:22 AM   #10
ASauer
Human being with feelings
 
Join Date: Jun 2013
Posts: 22
Default

Being new to prerelease builds of Reaper, is reaper654+dev0421a_universal.dmg all I need to test?
ASauer is offline   Reply With Quote
Old 04-22-2022, 03:14 AM   #11
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 15,848
Default

Yes, but we try to keep discussion of prerelease builds over in the prerelease forum, so if you wouldn't mind giving us any relevant feedback there that would be great.

https://forum.cockos.com/forumdisplay.php?f=37
schwa is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:20 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.