Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 09-17-2022, 05:51 AM   #1
elx
Human being with feelings
 
Join Date: Oct 2020
Location: The Netherlands
Posts: 2
Default Panning mode/law/taper bug? (FIXED)

Hello,

I have encountered what seems to be a bug in the panning mode/law/taper system, introduced with the new panning tapers in Reaper 6.65. Reaper 6.64 works OK. All this on Windows 10 21H1. What happens is this: When panning mode is set to 'stereo pan', panning a stereo source slightly to either side almost collapses the signal to panned mono. Panning further then increasingly widens it again to about normal at 50%. However, this does not happen for all pan laws and tapers. The ones I found to be affected are:
stereo pan > -6dB > all tapers
stereo pan > 0db > linear and hybrid taper

Here's a visual comparison between 6.67 and 6.64


And a project file demonstrating the issue, consisting of a source track ( T1 - Stereo Noise; no master send ) sending to seven child tracks with different pan law and pan taper settings. All pan modes set to the problematic 'stereo pan'. T2 just echoes the source. On my system T3 is OK while T4-8 are showing the weird narrowing ( it's worst at 1%, so I've set them all to that. ) Free Ozone Imager on Master track. Just exclusive solo any child track to view it's output.
https://forum.cockos.com/attachment....1&d=1663416124
Attached Images
File Type: png Reaper Pan Bug.png (62.5 KB, 13 views)
elx is offline   Reply With Quote
Old 09-17-2022, 06:31 AM   #2
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 13,637
Default

Hmm, thanks for the report. Thinking about the cleanest fix.
schwa is offline   Reply With Quote
Old 09-17-2022, 09:45 AM   #3
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 13,637
Default

This should hopefully be fixed in the latest development build of REAPER. It would be very helpful if you were willing to test it out and let us know if you think this is resolved.

Pre-release information here:
https://forum.cockos.com/forumdisplay.php?f=37
schwa is offline   Reply With Quote
Old 09-17-2022, 01:23 PM   #4
elx
Human being with feelings
 
Join Date: Oct 2020
Location: The Netherlands
Posts: 2
Default

Happy to help, so I've installed the pre-release and ran the little test project. And am happy to report that all previously affected laws/tapers behave correctly now. That was a super quick fix indeed. Much obliged!
elx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:57 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.