Old 10-10-2010, 09:01 AM   #1
carbon
Human being with feelings
 
carbon's Avatar
 
Join Date: Feb 2008
Location: Eesti
Posts: 2,309
Default MacBook Pro + Win7 DPC (was Stealth Pedal) Problem

Got my hands on the IK Multimedia Stealth Pedal audio interface / MIDI controller.

The problem is: i can't get a crackle free sound out of it.
Adjusting the ASIO buffer size decreases the crackling, but does not completely get rid of it.



The computer is a MacBook Pro 13" laptop (2.4GHz, 4GB RAM), running Win7 64bit, REAPER 32bit.
Using the latest drivers for Vista 64 from IK Multimedia.

Any ideas what to test?
Right now the Stealth Pedal is useless as an audio interface.
__________________
KasparTORN

Last edited by carbon; 10-17-2010 at 02:22 AM. Reason: Inaccurate title
carbon is offline   Reply With Quote
Old 10-14-2010, 11:34 AM   #2
carbon
Human being with feelings
 
carbon's Avatar
 
Join Date: Feb 2008
Location: Eesti
Posts: 2,309
Default

Any ideas, suggestions what to look for?

Additional information:
1) If selecting the Stealth Pedal ASIO driver, then without any plugins the sustained CPU usage goes up to about 10-15%
2) If using internal soundcard with ASIO4All driver, the CPU usage is something between 1-3%

* I got a blue screen crash while switching from ASIO4All to StealthPedal using MiniHost (trying if things were better in other hosts - not).

Is it possible to use ASIO4All drivers for an USB audio interface - to see if the drivers are the culprit?
__________________
KasparTORN
carbon is offline   Reply With Quote
Old 10-14-2010, 12:54 PM   #3
carbon
Human being with feelings
 
carbon's Avatar
 
Join Date: Feb 2008
Location: Eesti
Posts: 2,309
Default Latency Monitor

I used this program to check for problems:
http://www.resplendence.com/latencymon_using

Things seem bad, but I'm not sure how to proceed?
__________________
KasparTORN
carbon is offline   Reply With Quote
Old 10-15-2010, 04:45 AM   #4
carbon
Human being with feelings
 
carbon's Avatar
 
Join Date: Feb 2008
Location: Eesti
Posts: 2,309
Default

Disabling NVIDIA graphics drivers and ACPI battery control drivers had positive results for DSP and ISR but negative for hard page fault:



I also tried the Powermizer program to fix a NVIDIA driver's issue discussed here:
http://forums.nvidia.com/index.php?s...=157614&st=420
http://somemorebytes.com/wp/index.ph...e/nvpmmanager/

But it didn't have a positive effect...
__________________
KasparTORN
carbon is offline   Reply With Quote
Old 10-15-2010, 06:03 AM   #5
carbon
Human being with feelings
 
carbon's Avatar
 
Join Date: Feb 2008
Location: Eesti
Posts: 2,309
Default MacBook Pro not suitable...

Well who would've thought:
http://www.notebookcheck.net/Review-...z.18780.0.html

Quote:
Hence, the MacBookPro 13 (like the 15 as well) is not suitable for the use with an external sound card with Windows at the moment.
__________________
KasparTORN
carbon is offline   Reply With Quote
Old 10-16-2010, 03:00 AM   #6
carbon
Human being with feelings
 
carbon's Avatar
 
Join Date: Feb 2008
Location: Eesti
Posts: 2,309
Default MacBook Pro + Win7 - Any Good?

Hey, It's me again

Anybody getting any recording work done with MacBook pro under Win7?

Installing NVIDIA's latest beta drivers gave me somewhat workable results:
http://www.nvidia.com/object/noteboo...ta-driver.html

DPC around 1300 µs
ACPI battery control drivers disabled
ASIO buffer 194 samples

With 15.4 I/O latency this is far from ideal, also the DPC is just about below the yellow, so the system feels unreliable - working at the limit waiting for something to happen that nudges me over the edge.
__________________
KasparTORN
carbon is offline   Reply With Quote
Old 10-20-2010, 11:37 PM   #7
carbon
Human being with feelings
 
carbon's Avatar
 
Join Date: Feb 2008
Location: Eesti
Posts: 2,309
Default Alternative Drivers?

And more...

At the moment I settled to disable the NVIDIA graphic drivers completely, also the ACPI battery control drivers.
Now I can run the StealthPedal at the lowest buffer size (96).

But I'm still wondering - is there an alternative?
Are there any alternative graphics drivers or ACPI drivers made by audio enthusiasts out there?

Anybody tried these, any good?
http://www.tweakforce.com/modules.php?name=Downloads

Or RivaTuner - I tried, but seems my NVIDIA card model isn't supported?
http://downloads.guru3d.com/RivaTune...nload-163.html
__________________
KasparTORN
carbon is offline   Reply With Quote
Old 12-05-2010, 09:52 PM   #8
marcus82
Human being with feelings
 
Join Date: Jan 2008
Posts: 189
Default

carbon looks like the community let you down this time.

i have the same issue and its quite annoying. On top of that i couldn't try your suggestion of disabling the video card driver. My video card does not show up in the device manager.

hopefully someone can provide some solutions
marcus82 is offline   Reply With Quote
Old 12-06-2010, 02:40 AM   #9
carbon
Human being with feelings
 
carbon's Avatar
 
Join Date: Feb 2008
Location: Eesti
Posts: 2,309
Default

Quote:
Originally Posted by marcus82 View Post
On top of that i couldn't try your suggestion of disabling the video card driver. My video card does not show up in the device manager.
You don't have it under "Display Adapters"?
__________________
KasparTORN
carbon is offline   Reply With Quote
Old 12-06-2010, 04:25 AM   #10
Ollie
Super Moderator (no feelings)
 
Ollie's Avatar
 
Join Date: Dec 2007
Location: On or near a dike
Posts: 9,705
Default

Stupid question: On which USB port are you using the StealthPlug? Until recently, I didn't know that it's not recommended to use audio interfaces on the left-hand USB ports on some Macbooks.
Ollie is offline   Reply With Quote
Old 09-11-2013, 07:48 AM   #11
khushalbhadra
Human being with feelings
 
Join Date: Sep 2009
Posts: 86
Default

Well even my Stealth Pedal doesnt work with Asio4all on Windows 8 OS. Any solution guys?
khushalbhadra is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 05:47 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.