COCKOS
CONFEDERATED FORUMS
Cockos : REAPER : NINJAM : Forums
Forum Home : Register : FAQ : Members List : Search :

Go Back   Cockos Incorporated Forums > NINJAM Discussion > User Discussion

Reply
 
Thread Tools Display Modes
Old 07-17-2011, 06:26 PM   #1
mecctro
Human being with feelings
 
Join Date: Jul 2011
Posts: 2
Default Midi Sync and Asio, same Ninjam client

After some frustration with not having Asio and Midi sync available at the same time, I took a look around for solutions. Nothing really worked since the wasabi client didnt support Asio.

Here's the solution.
Download the Ninjam wasabi client here (It provides midi sync capabilities): Download

Unzip the files into a folder somewhere. Download the attached njasiodrv.dll (inside of njasiodrv.zip), then place it inside the folder that you made for the Ninjam wasabi client.

It should look like this:


Run the client and Asio support should now be enabled.

This file does not contain a virus, here is a scan: Scan


Hope this helps people in a similar circumstance.
Attached Images
File Type: jpg folder.jpg (41.8 KB, 754 views)
Attached Files
File Type: zip njasiodrv.zip (152.3 KB, 222 views)

Last edited by mecctro; 07-18-2011 at 10:22 AM.
mecctro is offline   Reply With Quote
Old 04-11-2015, 11:39 AM   #2
neovalis
Human being with feelings
 
Join Date: Apr 2015
Location: Detroit, MI
Posts: 3
Default very gradual drift

This is working extremely well for me with outboard gear. But, I've noticed that the midi clock sync drifts very slowly over long period of time. I can correct for this as it drifts using the main control on the Sync-Shift MK-III (which allows me to adjust clock latency between my gear and my computer) but I only have about 20-30 minutes before I run out of travel in the control and must stop and resync. I've noticed that raising the process priority of wasabi_ninjam.exe to realtime seems to help a little. Any thoughts on this?

-Matt G
neovalis is offline   Reply With Quote
Old 04-11-2015, 07:14 PM   #3
mecctro
Human being with feelings
 
Join Date: Jul 2011
Posts: 2
Default It's been... awhile

It's been quite a long time since I looked at this (the day I originally posted this some 3+ years ago), but if you want I can take a look at it again and do some testing on Win 7 and see if I can fix the issue.

I'm fairly certain I compiled this on Win XP and don't remember that being an issue, but I could have overlooked it at the time.

Let me see if I can find the source and fix the problem, no promise though, it's been ages since I've looked at it and I'm not sure I have a copy anymore (or that anyone has a copy of Wasabi for that matter).

I'll let you know one way or the other.

edit: I just saw in your other post you are hosting some ninjam servers, I'll do my latency testing there.

Last edited by mecctro; 04-11-2015 at 07:22 PM.
mecctro is offline   Reply With Quote
Old 10-18-2015, 08:29 PM   #4
dinoc
Human being with feelings
 
Join Date: Jan 2006
Posts: 14
Default This is really cool

mecctro,
I just found your client, I knew ninjam since quite a long time and didnt know there was a version with midi sync, really wished reaper had such functionality in reaninjam, but well.
I'm still to manage to get reaper to sync correctly to this client,
but meanwhile i'm playing around with the mobius loop app (theres also a 32bit vst) to sync to ninjam servers and works nicely.
I've set your client to send midi time sync to the mobius app via loopbe (virtual midi loop device).
I've got 4 tracks in mobius where I record my electric guitar, the first track, the master, syncs to the midi device, so it syncs to ninjam, the other tracks are slaves to the first track
As neovalis mentioned it actually misses a few beats now and then. Mobius has a display that shows the current bpm/bar/beat. For example, if the ninjam server is working with 130bpm, mobius shows almost all the time 130.0 bpm, but at some point, for about 1 or 2 seconds it shows 129.8bpm, and it slightly and slowly starts to drift from the metro sync. At the beginning.
Attached Images
File Type: jpg 130bpm correct.JPG (54.5 KB, 143 views)
File Type: jpg 129.8bpm miss.JPG (50.7 KB, 134 views)

Last edited by dinoc; 10-18-2015 at 08:34 PM. Reason: images
dinoc is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:58 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.